Bug 1125964 - Evolution keeps asking for GOA Google Calendar's password
Summary: Evolution keeps asking for GOA Google Calendar's password
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1132954 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-01 13:16 UTC by Yajo
Modified: 2014-09-18 12:01 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-18 11:49:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 735311 None None None Never

Description Yajo 2014-08-01 13:16:37 UTC
Description of problem:
I have many accounts configured with GOA. 2 of them are from Google. Until recently, everything worked OK, but now when I log in my desktop, a dialog pops up asking for my Google Calendar password. That itself is weird, because it should not be needed, but when I enter the password it says it's wrong (but it is not), which is even weirder.


Version-Release number of selected component (if applicable):
gnome-online-accounts-3.10.5-1.fc20.x86_64


How reproducible:
At login. If I press cancel, then the next time I try to access my calendar.

Steps to Reproduce:
1. Configure a Google account.

Actual results:
Pop up asking for calendar password. Entering password says it's wrong, always.


Expected results:
GOA takes care of auth, and no dialogs pop up.

Comment 1 Mads 2014-08-03 19:09:14 UTC
I can confirm the above, it happens on both my systems.

Comment 2 Gregor Hlawacek 2014-08-20 13:55:57 UTC
Same here. same version happens on both of my machines

Comment 3 John Thacker 2014-08-20 22:03:04 UTC
I'm seeing this with 3.10.5-1.
A bunch of users have reported this in GNOME Bugzilla as well. g-o-a 3.10.2-1 works fine according to some users.

Comment 4 John Thacker 2014-08-20 22:12:40 UTC
However, for me I get the same error with g-o-a 3.10.2-1. Mail in evolution works fine, but the Calendar repeatedly asks for the password and always claims it is incorrect. This occurs with 2 step authentication turned off or turned on with Google.

Comment 5 Debarshi Ray 2014-09-18 12:01:50 UTC
*** Bug 1132954 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.