Bug 112601 - dmallocthcxx (C++-safe, thread-safe dmalloc) does not work
dmallocthcxx (C++-safe, thread-safe dmalloc) does not work
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: dmalloc (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-24 01:32 EST by Scott Lamb
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 10:23:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
demonstration program (1002 bytes, text/plain)
2003-12-24 01:32 EST, Scott Lamb
no flags Details

  None (edit)
Description Scott Lamb 2003-12-24 01:32:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
The dmallocthcxx library, which is supposed to be a version of dmalloc
safe for multiple threads and C++, is apparently not. It claims to
become reentrant; I do not use it from within a signal handler, so the
only way this could happen is by not locking properly when used by
multiple threads simultaneously.

Version-Release number of selected component (if applicable):
dmalloc-4.8.1-12

How reproducible:
Always

Steps to Reproduce:
1. Download the soon-to-be-attached dmallocthcxx-crash.cc
2. Compile with gcc -Wall dmallocthcxx-crash.cc -o dmallocthcxx
-ldmallocthcxx -lpthread
3. Run with ./dmallocthcxx-crash

Actual Results:  $ ./dmallocthcxx-crash
debug-malloc library: halting program, fatal error
   Error: malloc library has gone recursive (err 11)


Expected Results:  Looping forever with no output

Additional info:
Comment 1 Scott Lamb 2003-12-24 01:32:52 EST
Created attachment 96689 [details]
demonstration program
Comment 2 Gene Czarcinski 2004-01-21 09:00:17 EST
You might want to get the latest version of dmalloc (5.2.4) ... it
might fix things ... http://dmalloc.com
Comment 3 Jakub Jelinek 2004-10-19 10:23:32 EDT
Can't reproduce with dmalloc-5.3.0-3.

Note You need to log in before you can comment on or make changes to this bug.