Bug 1126078 - Missing feature: simultaneous different operations
Summary: Missing feature: simultaneous different operations
Keywords:
Status: CLOSED DUPLICATE of bug 963137
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 20
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-01 19:44 UTC by Göran Uddeborg
Modified: 2014-08-14 18:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-14 07:15:54 UTC


Attachments (Terms of Use)

Description Göran Uddeborg 2014-08-01 19:44:40 UTC
Description of problem:
In some situations, a clean transaction can be done by simultaneously removing one package and installing another.  If these are Fedora packages, they might have Obsoletes/Provides tags to facilitate this, but when installing external packages there might not always be the necessary information in the packages.

With yum, such things could be done using the "shell" subcommand.  In that, one could ask for one installation, another removal, maybe a third upgrade, and then run all these as one unit.

With dnf, there doesn't seem to be any clean way to do this.


Additional info:
It is of course possible to do this using "rpm --nodeps" or "--force" and similar hacks.  But I'm looking for a clean way here.

Comment 1 Ales Kozumplik 2014-08-14 07:15:54 UTC
Hello Goran, this is already possible with --allowerasing. See bug 963137.

*** This bug has been marked as a duplicate of bug 963137 ***

Comment 2 Göran Uddeborg 2014-08-14 18:07:32 UTC
I wonder why I missed that one while searching.  But anyway, I'll use that the next time.  Thanks for the reply!


Note You need to log in before you can comment on or make changes to this bug.