Bug 1126086 - KERNEL ABI COMPATIBILITY WARNING when building any kmod package on RHEL7.0
Summary: KERNEL ABI COMPATIBILITY WARNING when building any kmod package on RHEL7.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: redhat-rpm-config
Version: 7.1
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Minfei Huang
QA Contact: Karel Srot
URL:
Whiteboard:
Depends On:
Blocks: 1024341
TreeView+ depends on / blocked
 
Reported: 2014-08-01 20:24 UTC by Sam Roza
Modified: 2019-07-11 08:06 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 13:33:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0567 normal SHIPPED_LIVE redhat-rpm-config bug fix update 2015-03-05 17:07:37 UTC

Description Sam Roza 2014-08-01 20:24:14 UTC
Description of problem:

When customer builds any package using the following command, he is given a kABI compatibility warning:

# rpmbuild -bb SPECS/hello.spec


Version-Release number of selected component (if applicable):

9.1.0-63-el7

How reproducible:

Very easily




Steps to Reproduce:
1. Install redhat-rpm-config
2. Try to build package: rpmbuild -bb SPECS/hello.spec
3. Review error, below

Actual results:

$ rpmbuild -bb SPECS/hello.spec
[...]
Finding  Requires: /usr/lib/rpm/redhat/find-requires

********************************************************************************
*********************** KERNEL ABI COMPATIBILITY WARNING ***********************
********************************************************************************
The kernel ABI reference files (provided by kabi-whitelists) were not found.
No compatibility check was performed. Please install the kABI reference files
and rebuild if you would like to verify compatibility with kernel ABI.
[...]
==============

Examining "/usr/lib/rpm/redhat/find-requires.ksyms", it looks for the
kabi whitelist under "/lib/modules/kabi/kabi_whitelist_$arch".  However,
there is no such path:
==============
$ rpm -qf /usr/lib/rpm/redhat/find-requires.ksyms
redhat-rpm-config-9.1.0-63.el7.noarch
$ rpm -q kernel-abi-whitelists
kernel-abi-whitelists-3.10.0-123.4.2.el7.noarch
$ ls -l /lib/modules
total 12
drwxr-xr-x. 6 root root 4096 Jun 11 18:40 3.10.0-123.1.2.el7.x86_64
drwxr-xr-x. 7 root root 4096 Jun 27 15:22 3.10.0-123.4.2.el7.x86_64
drwxr-xr-x. 2 root root   88 Jul  3 11:37 kabi-rhel70
==============

Expected results:

Expected that package will be properly built.

Additional info:

One can create a symlink to resolve the error: $ sudo ln -s kabi-rhel70 /lib/modules/kabi

But there appear to be some side-effects to doing that as well. See below:

===================
$ rpmbuild -bb SPECS/hello.spec
[...]
Finding  Requires: /usr/lib/rpm/redhat/find-requires

********************************************************************************
*********************** KERNEL ABI COMPATIBILITY WARNING ***********************
********************************************************************************
The following kernel symbols are not guaranteed to remain compatible with
future kernel updates to this RHEL release:

        __fentry__
        module_layout
[...]
$ rpm -qf /usr/lib/rpm/redhat/find-requires.ksyms
redhat-rpm-config-9.1.0-63.el7.noarch
$ rpm -q kernel-abi-whitelists
kernel-abi-whitelists-3.10.0-123.4.2.el7.noarch
===================

At least the "module_layout" symbol is in the RHEL6.5 kabi whitelist:
===================
$ egrep '__fentry__|module_layout' /lib/modules/kabi-rhel65/kabi_whitelist_x86_64 
        module_layout
$

Comment 4 Dave Young 2014-08-18 08:00:45 UTC
Karel, can you help provide qa_ack?

Comment 11 Weiping Pan 2014-11-12 08:07:11 UTC
brew build finished, set state with MODIFIED.

Comment 12 Weiping Pan 2014-11-12 08:16:01 UTC
Hi, Sam,

Can you try redhat-rpm-config-9.1.0-68.el7.noarch.rpm ?

https://brewweb.devel.redhat.com/buildinfo?buildID=398274

thanks
Weiping Pan

Comment 14 Akemi Yagi 2014-11-12 09:17:52 UTC
Hi Weiping,

Is it too late to be included in 7.1 ?

Comment 15 Jimmy Pan 2014-11-25 07:25:20 UTC
Hi all,

I think the path might be wrong. It should be:
ls /lib/modules/kabi-*
/lib/modules/kabi-current:
kabi_whitelist_ppc64  kabi_whitelist_s390x  kabi_whitelist_x86_64

/lib/modules/kabi-rhel70:
kabi_whitelist_ppc64  kabi_whitelist_s390x  kabi_whitelist_x86_64

/lib/modules/kabi-rhel71:
kabi_whitelist_ppc64  kabi_whitelist_s390x  kabi_whitelist_x86_64


not /lib/modules/kabi/kabi_whitelist_$arch

Thanks.

Comment 22 errata-xmlrpc 2015-03-05 13:33:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0567.html


Note You need to log in before you can comment on or make changes to this bug.