Bug 1126101 - puppet unable to resolve domain name of neutron node
Summary: puppet unable to resolve domain name of neutron node
Keywords:
Status: CLOSED DUPLICATE of bug 1124027
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 6)
Hardware: x86_64
OS: Unspecified
medium
unspecified
Target Milestone: ---
: 5.0 (RHEL 7)
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-01 21:16 UTC by Jaroslav Henner
Modified: 2014-09-08 05:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-04 11:42:01 UTC


Attachments (Terms of Use)

Description Jaroslav Henner 2014-08-01 21:16:07 UTC
Description of problem:
when deploying with the br-ex provisioning enabled, the puppet on the neutron node failed to resolve. after adding the staypuft server address to resolve.conf, things got fixed. My guess it is because the dhclient replaced the resolv.conf after adding the eth* to the bridge. 

There was a line:
; generated by /usr/sbin/dhclient-script
in the resolv.conf



Version-Release number of selected component (if applicable):
rhel-osp-installer-0.1.6-4.el6ost.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Warning: Unable to fetch my node definition, but the agent run will continue:
Warning: getaddrinfo: Name or service not known
Info: Retrieving plugin
Error: /File[/var/lib/puppet/lib]: Failed to generate additional resources using 'eval_generate': getaddrinfo: Name or service not known
Error: /File[/var/lib/puppet/lib]: Could not evaluate: Could not retrieve file metadata for puppet://staypuft.example.com/plugins: getaddrinfo: Name or service not known
Wrapped exception:
getaddrinfo: Name or service not known
Error: Could not retrieve local facts: no address for neutron.example.com
Error: Failed to apply catalog: Could not retrieve local facts: no address for neutron.example.com
Error: Could not send report: getaddrinfo: Name or service not known

Comment 2 Mike Burns 2014-08-04 11:42:01 UTC
This issue showed up in bug 1124027 and was fixed in openstack-puppet-modules.  the PEERDNS option was not copied to br-ex when it was created.

*** This bug has been marked as a duplicate of bug 1124027 ***


Note You need to log in before you can comment on or make changes to this bug.