Bug 1126118 - yum install @development not working
Summary: yum install @development not working
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: yum
Version: 7.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Valentina Mukhamedzhanova
QA Contact: BaseOS QE Security Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-02 01:11 UTC by notklaatu
Modified: 2016-05-01 07:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-10 16:14:02 UTC


Attachments (Terms of Use)

Description notklaatu 2014-08-02 01:11:51 UTC
Description of problem:
I try 
yum install @development

Version-Release number of selected component (if applicable):
RHEL 7.2

How reproducible:
100% on my system.
Seems to have occured to a few other people 
http://centos.distrosfaqs.org/centos/development-tools-install/
but not finding all that much online

Other groups, ie, yum install @xfce-desktop
works as expected


Steps to Reproduce:
1. su
2.
[root@localhost]# yum install @development
Loaded plugins: langpacks, product-id, subscription-manager
Nothing to do

3. rpm -q git 
package git is not installed



Actual results:
group is not installed.


Expected results:
group should be installed

Additional info:
other groups work. 
I have tried variations, ie, 
yum install "Development tools"
yum groupinstall "Development tools"
and so on, nothing installs this group.

yum groupinfo @development DOES show all the packages in the group but rpm -q $PACKAGE shows that they are not installed.

Comment 1 Valentina Mukhamedzhanova 2014-08-04 09:56:03 UTC
Hello, please provide the output of the following commands:

# yum group list -v
# yum group info "Development Tools" -v

Comment 2 Fedora End Of Life 2015-01-09 21:28:26 UTC
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 3 notklaatu 2015-01-29 10:48:42 UTC
Tried this again on RHEL7, still fails.

For instance:
# yum group list -v
[snip]
Development and Creative Workstation (developer-workstation-environment)

# yum install @developer-workstation-environment
Warning: Package group developer-workstation-environment does not exist.
Nothing to do.

# yum groupinstall "KDE Desktop"
[snip]
Install 106 Packages (+270 Dependency packages)
N

# yum groupinstall kde-desktop
[snip]
Install 106 Packages (+270 Dependency packages)
N



It's not just that group, either. For example:
# yum install @console-internet
Warning: Package group console-internet does not exist.
Nothing to do.



If this feature has been removed, then the docs here:
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Deployment_Guide/sec-Installing.html

should reflect the change.

Comment 7 Karel Srot 2015-12-15 14:52:33 UTC
I think there was a problem with an obsoleted package that was part of the group but it should be working now. Could you please confirm?

Comment 8 Valentina Mukhamedzhanova 2016-02-10 16:14:02 UTC
Seems to work for me, let's consider this resolved.

Comment 9 notklaatu 2016-05-01 07:35:40 UTC
I've switched to Fedora, which has switched to dnf, and that also appears to work. I think this one's done.


Note You need to log in before you can comment on or make changes to this bug.