Bug 1126131 - /media orphaned by a broken link to run/media
Summary: /media orphaned by a broken link to run/media
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: filesystem
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-02 07:20 UTC by lejeczek
Modified: 2014-10-03 12:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-03 12:45:16 UTC


Attachments (Terms of Use)

Description lejeczek 2014-08-02 07:20:56 UTC
Description of problem:

I went from 20 to rawhide, later there was some yum dependency problem at some point I tried yum update which must have gotten fixed, I don't know when but now I'm left with a broken link in /
media -> run/media
there is also:
/media.rpmmoved

what's the right config/structure?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Ondrej Vasik 2014-08-04 14:12:20 UTC
media.rpmmoved is the "safety" directory - when replacing /media with symlink, this directory is created to prevent potential data loss of user files placed in /media accidently.
You are right /run/media is not renewed automatically after the boot - it is only created once some media device is connected to the machine and thus /run/media/<dir> is created. It may probably be solved by having /run/media in /etc/tmpfiles.d and create it automatically after reboot - will check this with systemd guys.

Comment 2 Ondrej Vasik 2014-10-03 12:45:16 UTC
/media change was reverted in rawhide, closing worksforme, as there is nothing to fix now.


Note You need to log in before you can comment on or make changes to this bug.