Bug 1126161 - Backlight brightness issue with Toshiba Portege R830 after resume
Summary: Backlight brightness issue with Toshiba Portege R830 after resume
Keywords:
Status: CLOSED DUPLICATE of bug 1126159
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 21
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-02 21:52 UTC by Sylvain Pasche
Modified: 2014-08-04 18:12 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1126159
Environment:
Last Closed: 2014-08-04 18:12:00 UTC


Attachments (Terms of Use)
dmesg.log (62.39 KB, text/plain)
2014-08-02 21:52 UTC, Sylvain Pasche
no flags Details
dmi.log (12.67 KB, text/plain)
2014-08-02 21:52 UTC, Sylvain Pasche
no flags Details

Description Sylvain Pasche 2014-08-02 21:52:22 UTC
Created attachment 923522 [details]
dmesg.log

+++ This bug was initially created as a clone of Bug #1126159 +++

I reported bug 1126159 for Fedora 20. 
I gave a try with Fedora 21, the behavior is different:

By default the brightness control works well after the first boot. However, after a suspend/resume, changing the brightness has no effect and the actual brightness stays at 100%.

With the default kernel parameters
  ls /sys/class/backlight/
  acpi_video0  intel_backlight  toshiba

With the video.use_native_backlight=1 parameter
  The behavior doesn't change. Same issue as above.

  ls /sys/class/backlight/
  acpi_video0  intel_backlight  toshiba

With the acpi_backlight=vendor parameter:
  With this parameter the brightness stays at 100% after the first boot, it behaves like after a resume for the cases above.

  ls /sys/class/backlight/
  intel_backlight  toshiba

Comment 1 Sylvain Pasche 2014-08-02 21:52:53 UTC
Created attachment 923523 [details]
dmi.log

Comment 2 Hans de Goede 2014-08-04 18:12:00 UTC
Hi,

Thanks for also testing with F-21, and for letting us know that things behave slightly different with F-21, however  I think it is more productive to track this in a single bug (as it is likely a kernel issue, and F-20 will eventually get the new kernel from F-21 too).

So I'm going to mark this as a duplicate of your earlier bug, and then get back to you in the earlier bug.

Regards,

Hans

*** This bug has been marked as a duplicate of bug 1126159 ***


Note You need to log in before you can comment on or make changes to this bug.