Bug 1126172 - SELinux is preventing /usr/bin/abrt-dump-journal-oops from 'read' accesses on the chr_file urandom.
Summary: SELinux is preventing /usr/bin/abrt-dump-journal-oops from 'read' accesses on...
Keywords:
Status: CLOSED DUPLICATE of bug 1126037
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e72c600946bde2812c963cac0bc...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-03 04:15 UTC by birger
Modified: 2014-08-04 06:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-04 06:30:24 UTC


Attachments (Terms of Use)

Description birger 2014-08-03 04:15:14 UTC
Description of problem:
SELinux is preventing /usr/bin/abrt-dump-journal-oops from 'read' accesses on the chr_file urandom.

*****  Plugin catchall_boolean (89.3 confidence) suggests   ******************

If you want to allow global to ssp
Then you must tell SELinux about this by enabling the 'global_ssp' boolean.
You can read 'None' man page for more details.
Do
setsebool -P global_ssp 1

*****  Plugin catchall (11.6 confidence) suggests   **************************

If you believe that abrt-dump-journal-oops should be allowed read access on the urandom chr_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrt-dump-journ /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_dump_oops_t:s0
Target Context                system_u:object_r:urandom_device_t:s0
Target Objects                urandom [ chr_file ]
Source                        abrt-dump-journ
Source Path                   /usr/bin/abrt-dump-journal-oops
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-addon-kerneloops-2.2.2-4.fc21.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-68.fc21.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.16.0-0.rc7.git3.1.fc21.x86_64 #1
                              SMP Thu Jul 31 15:07:28 UTC 2014 x86_64 x86_64
Alert Count                   2
First Seen                    2014-08-02 13:12:06 CEST
Last Seen                     2014-08-03 06:11:06 CEST
Local ID                      dd563324-2b48-4579-83a1-7747e574c10b

Raw Audit Messages
type=AVC msg=audit(1407039066.249:35): avc:  denied  { read } for  pid=652 comm="abrt-dump-journ" name="urandom" dev="devtmpfs" ino=26 scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=system_u:object_r:urandom_device_t:s0 tclass=chr_file permissive=0


type=SYSCALL msg=audit(1407039066.249:35): arch=x86_64 syscall=open success=no exit=EACCES a0=7ff0ca878ee6 a1=80100 a2=0 a3=7ff0cb20b920 items=0 ppid=1 pid=652 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=abrt-dump-journ exe=/usr/bin/abrt-dump-journal-oops subj=system_u:system_r:abrt_dump_oops_t:s0 key=(null)

Hash: abrt-dump-journ,abrt_dump_oops_t,urandom_device_t,chr_file,read

Version-Release number of selected component:
selinux-policy-3.13.1-68.fc21.noarch

Additional info:
reporter:       libreport-2.2.3
hashmarkername: setroubleshoot
kernel:         3.16.0-0.rc7.git3.1.fc21.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2014-08-04 06:30:24 UTC

*** This bug has been marked as a duplicate of bug 1126037 ***


Note You need to log in before you can comment on or make changes to this bug.