Bug 1126175 - SELinux is preventing /usr/bin/abrt-dump-journal-oops from 'getattr' accesses on the filesystem /.
Summary: SELinux is preventing /usr/bin/abrt-dump-journal-oops from 'getattr' accesses...
Keywords:
Status: CLOSED DUPLICATE of bug 1126037
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a7f3d594d49e502f6d02d719264...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-03 04:17 UTC by birger
Modified: 2014-08-04 06:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-04 06:30:36 UTC


Attachments (Terms of Use)

Description birger 2014-08-03 04:17:49 UTC
Description of problem:
SELinux is preventing /usr/bin/abrt-dump-journal-oops from 'getattr' accesses on the filesystem /.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that abrt-dump-journal-oops should be allowed getattr access on the  filesystem by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrt-dump-journ /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_dump_oops_t:s0
Target Context                system_u:object_r:fs_t:s0
Target Objects                / [ filesystem ]
Source                        abrt-dump-journ
Source Path                   /usr/bin/abrt-dump-journal-oops
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-addon-kerneloops-2.2.2-4.fc21.x86_64
Target RPM Packages           filesystem-3.2-26.fc21.x86_64
Policy RPM                    selinux-policy-3.13.1-68.fc21.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.16.0-0.rc7.git3.1.fc21.x86_64 #1
                              SMP Thu Jul 31 15:07:28 UTC 2014 x86_64 x86_64
Alert Count                   5
First Seen                    2014-08-02 13:12:06 CEST
Last Seen                     2014-08-03 06:11:06 CEST
Local ID                      c8e5f684-c4bb-43f2-8c41-5a6a67f2b6dc

Raw Audit Messages
type=AVC msg=audit(1407039066.304:45): avc:  denied  { getattr } for  pid=652 comm="abrt-dump-journ" name="/" dev="sda3" ino=256 scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=system_u:object_r:fs_t:s0 tclass=filesystem permissive=0


type=SYSCALL msg=audit(1407039066.304:45): arch=x86_64 syscall=fstatfs success=no exit=EACCES a0=4 a1=7fff27b4c140 a2=8000 a3=7ff0cb20c8a0 items=0 ppid=1 pid=652 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=abrt-dump-journ exe=/usr/bin/abrt-dump-journal-oops subj=system_u:system_r:abrt_dump_oops_t:s0 key=(null)

Hash: abrt-dump-journ,abrt_dump_oops_t,fs_t,filesystem,getattr

Version-Release number of selected component:
selinux-policy-3.13.1-68.fc21.noarch

Additional info:
reporter:       libreport-2.2.3
hashmarkername: setroubleshoot
kernel:         3.16.0-0.rc7.git3.1.fc21.x86_64
type:           libreport

Potential duplicate: bug 1126139

Comment 1 Miroslav Grepl 2014-08-04 06:30:36 UTC

*** This bug has been marked as a duplicate of bug 1126037 ***


Note You need to log in before you can comment on or make changes to this bug.