Bug 1126205 - command id of the parent command isn't set for the child command task placeholders
Summary: command id of the parent command isn't set for the child command task placeho...
Keywords:
Status: CLOSED DUPLICATE of bug 1126204
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Ravi Nori
QA Contact:
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-03 14:45 UTC by Liron Aravot
Modified: 2016-02-10 19:18 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1126204
Environment:
Last Closed: 2014-08-04 17:12:55 UTC
oVirt Team: Infra


Attachments (Terms of Use)

Description Liron Aravot 2014-08-03 14:45:43 UTC
+++ This bug was initially created as a clone of Bug #1126204 +++

Description of problem:
Task placeholders aren't being cleared on failure to execute a command

How reproducible:
Always

Steps to Reproduce:
1. Execute a command which creates async task placeholders for it's child commands  when more than one child commands is supposed to be executed (for example - AddVmTemplate for vm with more than one disk)

Actual results:
The task placeholder record in the async_tasks table contains a different command id for each task placeholder (it's the id of the child command) which can cause to multiple execution of the parent command end method, makes it very hard to perform rca of issues as this command id is never logged.

Expected results:
All placeholders should have the same command id of the parent command.

logs are attached to the original bug.

Comment 1 Ravi Nori 2014-08-04 17:12:55 UTC
endAction is throwing constructor not error resulting in the endAction method being called multiple times. In normal execution the endAction is called only once.

This can be marked as duplicate of 1126204

*** This bug has been marked as a duplicate of bug 1126204 ***


Note You need to log in before you can comment on or make changes to this bug.