Bug 1126213 - engine throws IRSGenericExceptions on generation of OvfStore files
Summary: engine throws IRSGenericExceptions on generation of OvfStore files
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Liron Aravot
QA Contact: Pavel Stehlik
URL:
Whiteboard: storage
Depends On:
Blocks: 1109567
TreeView+ depends on / blocked
 
Reported: 2014-08-03 16:05 UTC by Ori Gofen
Modified: 2016-02-10 16:50 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-10 13:35:28 UTC
oVirt Team: Storage


Attachments (Terms of Use)
vdsm+engine logs (981.94 KB, application/gzip)
2014-08-03 16:05 UTC, Ori Gofen
no flags Details

Description Ori Gofen 2014-08-03 16:05:49 UTC
Created attachment 923638 [details]
vdsm+engine logs

Description of problem:
The operation of ProcessOvfUpdateForStorageDomainCommand calls 
SetVolumeDescriptionVDSCommand and IrsBrokerCommand , both failing with exceptions on engine

Version-Release number of selected component (if applicable):
beta.2

How reproducible:
100%

Steps to Reproduce:
1.view the flow of ProcessOvfUpdateForStorageDomainCommand from engine's logs

Actual results:
operation fails with exceptions

Expected results:


Additional info:

Comment 1 Liron Aravot 2014-08-04 06:37:44 UTC
Ori,
seems like the issue is in your storage, please verify that the disk exists on the storage.


The error that returns from vdsm is that the image path doesn't exist\can't be accessed.

the error:
--------------------------------------------------------------
2014-08-03 17:40:43,377 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand] (DefaultQuartzScheduler_Worker-16) [5775416] IrsBroker::Failed::SetVolumeDescriptionVDS due to: IRSErrorException: IRSGenericException: IRSErrorException: Failed to SetVolumeDescriptionVDS, error = Image path does not exist or cannot be accessed/created: (u'/rhev/data-center/mnt/10.35.160.108:_RHEV_ogofen_1/c267f94f-5538-493b-8103-6c04db40e035/images/b260892d-0e32-4e94-9f7b-d0c9e845c65d',), code = 254
--------------------------------------------------------------

that ovf disk was added on 11:05 -

2014-08-03 11:55:06,713 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.CreateImageVDSCommand] (DefaultQuartzScheduler_Worker-83) [339639e6] START, CreateImageVDSCommand( storagePoolId = 00000002-0002-0002-0002-0000000002ca, ignoreFailoverLimit = false, storageDomainId = c267f94f-5538-493b-8103-6c04db40e035, imageGroupId = b260892d-0e32-4e94-9f7b-d0c9e845c65d, imageSizeInBytes = 134217728, volumeFormat = RAW, newImageId = 136f60d0-653b-4302-b65e-6e84ff829e04, newImageDescription = OVF_STORE), log id: 4f71cab6



setting the description worked just fine -
--------------------------------------------------------------
2014-08-03 11:55:19,633 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.SetVolumeDescriptionVDSCommand] (org.ovirt.thread.pool-8-thread-10) [433dda3e] -- executeIrsBrokerCommand: calling 'setVolumeDescription' 
2014-08-03 11:55:19,632 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.SetVolumeDescriptionVDSCommand] (org.ovirt.thread.pool-8-thread-18) [17d6c196] START, SetVolumeDescriptionVDSCommand( storagePoolId = 00000002-0002-0002-0002-0000000002ca, ignoreFailoverLimit = false, storageDomainId = c267f94f-5538-493b-8103-6c04db40e035, imageGroupId = b260892d-0e32-4e94-9f7b-d0c9e845c65d, imageId = 136f60d0-653b-4302-b65e-6e84ff829e04), log id: 7f12d9e8
2014-08-03 11:55:19,639 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.SetVolumeDescriptionVDSCommand] (org.ovirt.thread.pool-8-thread-10) [433dda3e] -- setVolumeDescription parameters:
                spUUID=00000002-0002-0002-0002-0000000002ca
                sdUUID=27ee402b-e5ff-4d08-aa94-682cc022dcbd
                imageGroupGUID=80867011-6dd4-4b42-9b13-b35e04c262ce
                volUUID=ae0fa0e9-ade9-49c1-961c-ffd3ab3e4de3
                description={"Updated":false,"Disk Description":"OVF_STORE","Storage Domains":[{"uuid":"27ee402b-e5ff-4d08-aa94-682cc022dcbd"}],"Last Updated":null}

2014-08-03 11:55:19,735 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.SetVolumeDescriptionVDSCommand] (org.ovirt.thread.pool-8-thread-10) [433dda3e] FINISH, SetVolumeDescriptionVDSCommand, log id: 4dfa9806

---------------------------------------------------------------------

please verify that.

Comment 2 Ori Gofen 2014-08-04 07:39:33 UTC
yes you are right,a clean setup gives the required result, it seems the OvfStorFile got wiped out from the domain, I'll try to reproduce this one and update the right steps.

for now I have removed the blocker since,reproducing this bug has nothing with the OvfUpdate process ,we just see the effect when commencing OvfUpdate.

Comment 3 Liron Aravot 2014-08-10 12:49:20 UTC
Ori, any reason that this one can't be marked as verified?

Comment 4 Ori Gofen 2014-08-10 13:35:28 UTC
Well,mainly because,the bug still exist,the fact that I couldn't mange to reproduce it doesn't mean it should be verified.
I'm closing it on insufficient data.


Note You need to log in before you can comment on or make changes to this bug.