Bug 1126219 - It should be possible to specify proxy address and port for subscription manager
Summary: It should be possible to specify proxy address and port for subscription manager
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer
Version: Foreman (RHEL 6)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: Installer
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-03 17:25 UTC by Alessandro Vozza
Modified: 2016-11-08 04:08 UTC (History)
8 users (show)

Fixed In Version: rhel-osp-installer-0.1.9-1.el6ost
Doc Type: Enhancement
Doc Text:
A new feature has been added which gives users the ability to specify proxy information for subscription-manager details. This was added because many environments require a proxy between the host and CDN/RHN. Now, users can specify proxy information in the installer.
Clone Of:
Environment:
Last Closed: 2014-08-21 18:07:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1090 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-22 15:28:08 UTC

Description Alessandro Vozza 2014-08-03 17:25:25 UTC
Description of problem:

In deployments behind corporate proxies, it's sometime necessary to specify a proxy and its port or subscription-manager will fail. 

Version-Release number of selected component (if applicable):


How reproducible:

Either setup subscription-manager details during setup or define them as parameters after installation; try to provision a machine and register it with RHN, it will fail if a proxy is necessary to reach Red Hat' servers.

Steps to Reproduce:
1. Setup foreman and provision VM's/baremetal behind a proxy
2. use redhat_register snippet to register the provisioned hosts with Red Hat
3. watch it fail as there is no connection

Actual results:


Expected results:


Additional info:

This commit https://github.com/ams0/foreman-installer-staypuft/commit/d6b14846c9d84dcf5acf44eea51175d2fc53cab0 should fix it both in the provisioning template snippet and during initial installation.

Comment 5 Alexander Chuzhoy 2014-08-12 13:21:21 UTC
Verified: rhel-osp-installer-0.1.9-1.el6ost.noarch


The user is prompted to provide these:
1. Subscription manager username:
2. Subscription manager password:
3. Comma separated repositories:        rhel-7-server-openstack-5.0-rpms
4. Subscription manager pool (optional):
5. Subscription manager proxy hostname:
6. Subscription manager proxy port:
7. Subscription manager proxy username:
8. Subscription manager proxy password:
9. Proceed with configuration
10. Skip this step (provisioning won't subscribe your machines)

Comment 7 errata-xmlrpc 2014-08-21 18:07:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1090.html


Note You need to log in before you can comment on or make changes to this bug.