Bug 1126277 - [Admin GUI] in 'Add Users and Groups' dialog the column title should be freeze.
Summary: [Admin GUI] in 'Add Users and Groups' dialog the column title should be freeze.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: ovirt-4.2.0
: 4.2.0
Assignee: Jan Zmeskal
QA Contact: Jan Zmeskal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 04:49 UTC by Kobi Hakimi
Modified: 2019-04-28 13:32 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 11:32:45 UTC
oVirt Team: Infra
rule-engine: ovirt-4.2?
lsvaty: testing_plan_complete-
rule-engine: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack?


Attachments (Terms of Use)
the columns before scroll down - with titles (20.64 KB, image/png)
2014-08-04 04:50 UTC, Kobi Hakimi
no flags Details
the columns after scroll down - columns title disappeared (20.92 KB, image/png)
2014-08-04 04:52 UTC, Kobi Hakimi
no flags Details
Verification screenshot (42.06 KB, image/png)
2017-12-14 14:07 UTC, Jan Zmeskal
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 81064 master POST webadmin: Replace cell table with data grid 2017-08-28 16:03:45 UTC

Description Kobi Hakimi 2014-08-04 04:49:19 UTC
Description of problem:
[RHEVM GUI] in 'Add Users and Groups' dialog the columns title should be freeze.

Version-Release number of selected component (if applicable):
 Red Hat Enterprise Virtualization Manager Version: 3.4.0-0.21.el6ev 
 oVirt Engine Version: 3.5.0-0.0.master.20140715172116.git4687dc1.el6 

How reproducible:
Always

Steps to Reproduce:
1. Import LDAP with many users(more then 20)
2. Go to Users tab and click on Add.
3. Search for * and scroll the results down. 

Actual results:
The columns title scrolled with the users and groups  

Expected results:
The columns title should be freeze 

Additional info:
see attached snapshots

Comment 1 Kobi Hakimi 2014-08-04 04:50:49 UTC
Created attachment 923745 [details]
the columns before scroll down - with titles

Comment 2 Kobi Hakimi 2014-08-04 04:52:42 UTC
Created attachment 923746 [details]
the columns after scroll down - columns title disappeared

Comment 3 Yaniv Kaul 2017-06-07 17:19:30 UTC
Is this taken care of in the new UI design?

Comment 4 Alexander Wels 2017-06-07 17:23:45 UTC
I just verified this is still the case, but should not be that hard to fix. Have Oved prioritize it?

Comment 6 Kobi Hakimi 2017-06-08 07:42:55 UTC
Please try to think about any application that you use.
when you have some table and you scroll down...
and yep you find the desired row but now you need to guess what each column means cause the title disappeared.

Is this something that you can consider as not a bug??? 
IMHO when user have bad experience with GUI/flow is not good for our business :(

Comment 7 Oved Ourfali 2017-06-08 07:44:48 UTC
(In reply to Kobi Hakimi from comment #6)
> Please try to think about any application that you use.
> when you have some table and you scroll down...
> and yep you find the desired row but now you need to guess what each column
> means cause the title disappeared.
> 
> Is this something that you can consider as not a bug??? 
> IMHO when user have bad experience with GUI/flow is not good for our
> business :(

I haven't closed it as notabug.
I closed it as wontfix, as we can't prioritize this at the moment.
We are doing a lot of good things in the ui to improve the experience. We can't do them all.

Comment 8 Kobi Hakimi 2017-06-08 07:48:05 UTC
The question is, if it's still in the pipe? for future fix?

Comment 9 Oved Ourfali 2017-06-08 07:50:32 UTC
(In reply to Kobi Hakimi from comment #8)
> The question is, if it's still in the pipe? for future fix?

No.
Otherwise I would have kept it open.

Comment 10 Alexander Wels 2017-06-08 11:37:54 UTC
I don't understand why, it should be a relatively easy fix (put the scroll on the right part of the DOM). And I verified this is definitely still an issue.

Comment 11 Red Hat Bugzilla Rules Engine 2017-09-28 12:42:42 UTC
This request has been proposed for two releases. This is invalid flag usage. The ovirt-future release flag has been cleared. If you wish to change the release flag, you must clear one release flag and then set the other release flag to ?.

Comment 12 Jan Zmeskal 2017-12-14 13:35:47 UTC
Since this is an UI issue, it should not really matter if the users are from LDAP or any other directory server, am I right?

Comment 13 Kobi Hakimi 2017-12-14 13:43:29 UTC
(In reply to Jan Zmeskal from comment #12)
> Since this is an UI issue, it should not really matter if the users are from
> LDAP or any other directory server, am I right?

As you can see in the attached snapshots the main idea is that we have a lot of users which cause to columns title to disappear.
I took the LDAP cause its add many users quickly but you can add it with a script or in another way.

Comment 14 Jan Zmeskal 2017-12-14 14:07:50 UTC
Created attachment 1368008 [details]
Verification screenshot

Verified on 4.2.1-0.0.master.20171213162959.git55d2c1e.el7.centos
The column titles are indeed frozen in the upper part and don't disappear when scrolling

Comment 15 Sandro Bonazzola 2017-12-20 11:32:45 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.