Bug 1126287 - [GSS] (6.4.0) The value wait-time of the EJB bean statistic is not calculated
Summary: [GSS] (6.4.0) The value wait-time of the EJB bean statistic is not calculated
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: EJB
Version: 6.3.0
Hardware: All
OS: All
medium
medium
Target Milestone: DR1
: EAP 6.4.0
Assignee: Shailendra Jadhav
QA Contact: Jan Martiska
URL:
Whiteboard:
Depends On:
Blocks: 1126677
TreeView+ depends on / blocked
 
Reported: 2014-08-04 05:51 UTC by Jay SenSharma
Modified: 2019-08-19 12:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1126677 (view as bug list)
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)
Stateless_EJB_Ear.ear (1.90 KB, application/octet-stream)
2014-08-05 08:13 UTC, Jay SenSharma
no flags Details
Stateless_EJB_Client.jar (3.79 KB, application/x-java-archive)
2014-08-05 08:14 UTC, Jay SenSharma
no flags Details


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-333 Minor Closed The value wait-time of the EJB bean statistic is not calculated 2017-12-12 09:50:42 UTC

Description Jay SenSharma 2014-08-04 05:51:56 UTC
Description of problem:
----------------------
If the statistic for EJB calls is enabled with
/subsystem=ejb3:write-attribute(name=enable-statistics, value=true)
call statistics are calculated but the wait-time is never set even if a pool overload is forced.


Version-Release number of selected component (if applicable):
The issue is reproducible even in EAP 6.3.0 beta.

How reproducible:
- Deploy any EJB on EAP 6.3 and then after accessing the EJBs check the EJB Statistics using CLI like:

/deployment=TestEAR.ear/subdeployment=remoteEjbTwo.jar/subsystem=ejb3/stateless-session-bean=TestBean:read-resource(include-runtime=true)


Steps to Reproduce:
1.
2.
3.

Actual results:
---------------- 
- The "wait-time" is always returned as ["wait-time" => 0L]


Expected results:
----------------
- "wait-time" should have been set to the actual calculated value.


Additional info:

Comment 4 Jay SenSharma 2014-08-05 08:13:39 UTC
Created attachment 924122 [details]
Stateless_EJB_Ear.ear

Comment 5 Jay SenSharma 2014-08-05 08:14:04 UTC
Created attachment 924123 [details]
Stateless_EJB_Client.jar

Comment 7 Jan Martiska 2014-09-18 07:28:13 UTC
Verified in EAP 6.4.0.DR1.1.
A regression test for this written by me is coming soon, waiting for PR to be merged.

Comment 8 Kabir Khan 2014-09-26 12:04:48 UTC
Regression test https://github.com/jbossas/jboss-eap/pull/1711


Note You need to log in before you can comment on or make changes to this bug.