Bug 1126295 - "Cannot read VM list from ESX" when add vm to esx
Summary: "Cannot read VM list from ESX" when add vm to esx
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who
Version: 6.6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Radek Novacek
QA Contact: gaoshang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 06:08 UTC by Liushihui
Modified: 2016-12-01 00:33 UTC (History)
4 users (show)

Fixed In Version: virt-who-0.10-6.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 07:13:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1513 normal SHIPPED_LIVE virt-who bug fix and enhancement update 2014-10-14 01:22:23 UTC

Description Liushihui 2014-08-04 06:08:10 UTC
Description of problem:
When add vm to esx host on the vcenter, it will pop up error message including "Cannot read VM list from ESX" and RestlibException 

Version-Release number of selected component (if applicable):
subscription-manager-1.12.10-1.el6.x86_64
python-rhsm-1.12.5-1.el6.x86_64
virt-who-0.10-4.el6.noarch
katello-headpin-1.4.3.26-1.el6sam_splice.noarch
candlepin-0.9.6.4-1.el6sam.noarch

How reproducible:
Always

Steps to Reproduce:
1. Prepare RHEL6.6 with latest subscription-manager and virt-who installed. 
ESX host has been added to vcenter, And ESX host has three guest.
My test env as the following:
vCenter: 10.66.79.51
ESX host 1: 10.66.128.160
2. Configure virt-who in ESX mode as the following:
[root@hp-z220-03 ~]# cat /etc/sysconfig/virt-who 
    VIRTWHO_BACKGROUND=1
    # Enable debugging output.
    VIRTWHO_DEBUG=1
    VIRTWHO_INTERVAL=5
    # Register ESX machines using vCenter
    VIRTWHO_ESX=1
    # Option for ESX mode
    VIRTWHO_ESX_OWNER=ACME_Corporation
    VIRTWHO_ESX_ENV=Library
    VIRTWHO_ESX_SERVER=10.66.79.51
    VIRTWHO_ESX_USERNAME=administrator@vsphere.local
    VIRTWHO_ESX_PASSWORD=qwer1234P!
3.Start virt-who service
[root@hp-z220-03 ~]# service virt-who start
[root@hp-z220-03 ~]# service virt-who status
virt-who (pid  15975) is running...
4. Register the RHEL6.6 to SAM server
# Subscription-manager register --username=admin --password=admin
5. Monitor the rhsm log :
# tail -f /var/log/rhsm/rhsm.log
6. Bring up vclient which connect to vcenter, add a vm to esx host. Then check virt-who log

Actual results:
It will show "Cannot read VM list from ESX for host aee4ff00-8c33-11e2-994a-6c3be51d959a (len(obj) <= 1) "
2014-08-04 11:05:01,270 [INFO]  @subscriptionmanager.py:116 - Sending update in hosts-to-guests mapping: {aee4ff00-8c33-11e2-994a-6c3be51d959a: [564d0676-800c-ea35-b2f6-982fa056ae84], 44454c4c-4200-1034-8039-b8c04f503258: []}
2014-08-04 11:05:14,784 [ERROR]  @esx.py:246 - Cannot read VM list from ESX for host aee4ff00-8c33-11e2-994a-6c3be51d959a (len(obj) <= 1)
2014-08-04 11:05:15,093 [ERROR]  @esx.py:246 - Cannot read VM list from ESX for host aee4ff00-8c33-11e2-994a-6c3be51d959a (len(obj) <= 1)
2014-08-04 11:05:15,095 [INFO]  @subscriptionmanager.py:116 - Sending update in hosts-to-guests mapping: {aee4ff00-8c33-11e2-994a-6c3be51d959a: [564d0676-800c-ea35-b2f6-982fa056ae84], 44454c4c-4200-1034-8039-b8c04f503258: []}
2014-08-04 11:05:27,450 [INFO]  @subscriptionmanager.py:116 - Sending update in hosts-to-guests mapping: {aee4ff00-8c33-11e2-994a-6c3be51d959a: [423a7a70-0b36-406f-27c9-518ccc4e42b6, 564d0676-800c-ea35-b2f6-982fa056ae84], 44454c4c-4200-1034-8039-b8c04f503258: []}

Expected results:
It shouldn't show this kind of error message

Additional info:

Comment 2 Radek Novacek 2014-08-04 10:44:29 UTC
Do I understand it correctly that the error only appears when there is no guest on given host?

Comment 3 Liushihui 2014-08-05 14:46:28 UTC
I'm afraid not. because it appears this problem when there is a guest on given host. please see the log as the following. 
Meanwhile, I think it still needn't show this error message in the virt-who log if it's correct to appear this error when there is no guest on given host.


2014-08-04 11:05:01,270 [INFO]  @subscriptionmanager.py:116 - Sending update in hosts-to-guests mapping: {aee4ff00-8c33-11e2-994a-6c3be51d959a: [564d0676-800c-ea35-b2f6-982fa056ae84], 44454c4c-4200-1034-8039-b8c04f503258: []}
2014-08-04 11:05:14,784 [ERROR]  @esx.py:246 - Cannot read VM list from ESX for host aee4ff00-8c33-11e2-994a-6c3be51d959a (len(obj) <= 1)
2014-08-04 11:05:15,093 [ERROR]  @esx.py:246 - Cannot read VM list from ESX for host aee4ff00-8c33-11e2-994a-6c3be51d959a (len(obj) <= 1)
2014-08-04 11:05:15,095 [INFO]  @subscriptionmanager.py:116 - Sending update in hosts-to-guests mapping: {aee4ff00-8c33-11e2-994a-6c3be51d959a: [564d0676-800c-ea35-b2f6-982fa056ae84], 44454c4c-4200-1034-8039-b8c04f503258: []}
2014-08-04 11:05:27,450 [INFO]  @subscriptionmanager.py:116 - Sending update in hosts-to-guests mapping: {aee4ff00-8c33-11e2-994a-6c3be51d959a: [423a7a70-0b36-406f-27c9-518ccc4e42b6, 564d0676-800c-ea35-b2f6-982fa056ae84], 44454c4c-4200-1034-8039-b8c04f503258: []}

(In reply to Radek Novacek from comment #2)
> Do I understand it correctly that the error only appears when there is no
> guest on given host?

Comment 4 Radek Novacek 2014-08-08 09:07:40 UTC
Following upstream commit fixes the issue:

https://git.fedorahosted.org/cgit/virt-who.git/commit/?id=0e5e1d504bc9f35f890b123629f719ef3d155564

Comment 5 Radek Novacek 2014-08-08 14:50:11 UTC
Fixed in virt-who-0.10-6.el6.

Comment 7 Liushihui 2014-08-14 09:06:54 UTC
Verified it on virt-who-0.10-6.el6.

Comment 8 errata-xmlrpc 2014-10-14 07:13:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1513.html


Note You need to log in before you can comment on or make changes to this bug.