Bug 1126296 - Need documentation on how to package SY application in JAR, WAR and EAR
Summary: Need documentation on how to package SY application in JAR, WAR and EAR
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Documentation
Version: 6.0.0 GA
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: CR3
: 6.0.0
Assignee: Nichola Moore
QA Contact: Len DiMaggio
URL:
Whiteboard:
: 1152643 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 06:17 UTC by Tadayoshi Sato
Modified: 2018-12-06 17:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-30 10:08:50 UTC
Type: Enhancement


Attachments (Terms of Use)

Description Tadayoshi Sato 2014-08-04 06:17:03 UTC
Comprehensive documentation for how to package SwitchYard application in JAR, WAR, and EAR is missing.

You can find the community version at:
https://docs.jboss.org/author/display/SWITCHYARD/Deployment
so at least productisation of this documentation is necessary, but also a more verbose and comprehensible one with working examples would be better.

Comment 1 Alan Santos 2014-08-04 13:09:13 UTC
Just noting this will also need to incorporate Karaf and Fabric for 6.1

Comment 2 belong 2014-08-11 01:44:29 UTC
Tadayoshi,

The helpdesk quickstart mentioned in the community documentation is not included with the product. Do you know if any of the supplied product quickstarts demonstrate packaging as a WAR?

Regards,
Ben

Comment 3 belong 2014-08-11 02:50:11 UTC
(This information will be best placed in our new Administration & Configuration Guide.)

Comment 4 Tadayoshi Sato 2014-08-21 02:44:15 UTC
(In reply to belong from comment #2)
> The helpdesk quickstart mentioned in the community documentation is not
> included with the product. Do you know if any of the supplied product
> quickstarts demonstrate packaging as a WAR?

The demos/orders and demos/multiApp/web quickstarts included in FSW are both WAR apps. I think demos/orders is better for the demonstrating purpose.

But maybe it should be better to confirm with SOA-PM why demos/helpdesk is omitted from the product and if they think demos/orders can be used instead for the documentation purposes.

Comment 5 belong 2014-08-21 10:15:21 UTC
Email sent to soa-pm-list. Waiting on response.

Comment 7 Nichola Moore 2014-09-02 05:48:32 UTC
I have added topic 41611, Packaging for SwitchYard to the content spec for the FSW Admin and Config Guide 6.0.
This topic will also be added to the FSw Admin and Config Guide 6.1, but it will need to have the versions updated, and more information added for Karaf.

Comment 8 belong 2014-09-02 06:56:43 UTC
Thank you, Nichola!

Just a few suggestions:

Do you think it would be a good idea to split this into two topics: 'Packaging SwitchYard Applications' and 'Deploying SwitchYard Applications', with the content currently under 'Available Runtimes' in the latter?

"SwitchYard 1.0 supports deployment into JBoss EAP 6.1.": I think that in the community it is important to mention versions, but for the product, I don't think users should have to care about versions. I think we can assume the versions are those shipped with the product. The versions of community components used are provided elsewhere already if they really want to know. Also, perhaps we should not present this from the perspective of SwitchYard, but the perspective of the product or user. "You can deploy SwitchYard applications on the application server (JBoss EAP) using..."

"EAP": "JBoss EAP" is the shortest abbreviation we're supposed to use.

What do you think?

Comment 9 Nichola Moore 2014-09-03 01:59:51 UTC
I think you're right!  I'll split them and amend the focus.

Comment 12 belong 2014-09-19 07:10:40 UTC
Thank you, Tadayoshi. This is valuable feedback.

Although I agree that for 6.0 we can remove the heading 'Available Runtimes', I am not sure about changing the phrase "You can deploy SwitchYard applications into JBoss EAP using..."

The way I see it, applications are still deployed on JBoss EAP. I think it is confusing to say that they are deployed on FSW, since FSW is simply a set of components. This will be even more important to make clear in 6.2, in which applications will be deployed on either JBoss EAP or JBoss Fuse, depending on their installation.

Comment 13 Tadayoshi Sato 2014-09-19 07:24:35 UTC
Hi Ben,

I understand your point and it makes sense considering 6.2 supports both EAP and Fuse.

By the phrase "You can deploy SwitchYard applications into JBoss EAP using...", I just felt wary about readers misunderstanding that SY applications can literaly be deployed into JBoss EAP, not only FSW. Of course, users cannot deploy SY apps into a JBoss EAP distribution.

If you can think of any better phrases that make both points clear, that would be great.

-- Tadayoshi

Comment 14 belong 2014-09-22 00:09:30 UTC
Thank you for your input, Tadayoshi. Perhaps for 6.0, something like: "You can deploy SwitchYard applications on the server using..."

Comment 15 Nichola Moore 2014-09-22 06:54:18 UTC
Thanks, Tadayoshi. I was on leave but I'll get straight on to these very useful contributions.

Comment 16 Tomas Rohovsky 2014-10-15 07:27:54 UTC
*** Bug 1152643 has been marked as a duplicate of this bug. ***

Comment 17 Nichola Moore 2014-10-22 00:29:12 UTC
After consideration and discussion, I have made the changes suggested by Tadayoshi. 

The following topics have been updated:

41611 revision 717993
41633 revision 711806

I've uncommented these topics in the Administration and Configuration Guide - Working Copy content spec under the title 'Packaging and Deployment for Switchyard'.

They are now ready for review.

Comment 18 belong 2014-10-28 00:25:22 UTC
Further update:

41611 revision 719559
41633 revision 711806

Comment 19 belong 2014-10-28 05:54:24 UTC
Len,

I have created another bug (Bug 1157948) for fleshing out our content on packaging and deploying, but can you please verify these small additions in the meantime?

http://docbuilder.usersys.redhat.com/22940/#sect-Packaging_and_Deployment_for_Switchyard

http://docbuilder.usersys.redhat.com/22940/#Deployment_for_SwitchYard

Regards,
Ben

Comment 21 Len DiMaggio 2014-10-28 12:39:54 UTC
Verifying this bugzilla as additional documentation will be addressed in https://bugzilla.redhat.com/show_bug.cgi?id=1157948

Comment 22 belong 2014-10-28 12:54:59 UTC
Thanks, Len.

Nichola, please proceed to follow 'BZ Process: VERIFIED 6.0 bugs' at [1].

[1] https://mojo.redhat.com/docs/DOC-948079

Comment 23 Nichola Moore 2014-10-28 23:32:36 UTC
I have uncommented the Packaging and Deployment for SwitchYard section and updated the revision numbers to those shown at comment 18 above in production content spec 22591 (Administration and Configuration Guide).
The revision number for this change is 719677.

Comment 24 belong 2014-10-29 03:43:05 UTC
Thanks, Nichola! And thank you much for the clear comment above.

Comment 25 nshendye 2014-10-30 10:08:50 UTC
Published to customer portal.

Build: Red_Hat_JBoss_Fuse_Service_Works-Administration_and_Configuration_Guide-6-web-en-US-6.0.0-17.el6eng


Note You need to log in before you can comment on or make changes to this bug.