Bug 1126298 - Unable to boot when systemd's LogTarget is set to syslog-or-kmsg or syslog
Summary: Unable to boot when systemd's LogTarget is set to syslog-or-kmsg or syslog
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: Frantisek Sumsal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 06:31 UTC by GV
Modified: 2015-11-19 14:57 UTC (History)
5 users (show)

Fixed In Version: systemd-219-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 14:57:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2092 normal SHIPPED_LIVE systemd bug fix and enhancement update 2015-11-19 12:13:57 UTC

Description GV 2014-08-04 06:31:17 UTC
Description of problem:
Unable too boot is LogTarget in /etc/systemd/system.conf is set to syslog-or-kmsg or syslog.

Version-Release number of selected component (if applicable):
systemd 208-11

How reproducible:
Change LogTarget in /etc/systemd/system.conf to syslog-or-kmsg or syslog and reboot.

Actual results:
System cannot boot.

Expected results:
System boot normally.

Additional info:
I know systemd is really BAD (use-it since it was introduced to Fedora) but since is "community" linux I can more ol less accept-it like it is. But you people made-it even worse in RHEL7!

Comment 2 Lukáš Nykrýn 2014-08-04 11:18:18 UTC
Thanks for the bug report, we always appreciate constructive criticism. We need to backport http://cgit.freedesktop.org/systemd/systemd-stable/commit/?id=b7f2e5ac769ca4d9b7d28050ec662104635a7822

Comment 3 GV 2014-08-04 16:33:00 UTC
> If journald cannot process a message from PID1 for 10 ms then something is
> significantly wrong. It's better to lose the message and continue.
Really? Lose the message? That's the best systemd can do?

Comment 4 Lennart Poettering 2014-08-04 19:54:42 UTC
In PID the effective difference between "syslog" and "journal" is pretty minimal. We should probably stop documenting "syslog" and just implicitly turn all "syslog" log targets into "journal".

Comment 5 Lukáš Nykrýn 2014-09-29 10:26:17 UTC
Ok, dropping log messages even just from systemd itself isn't probaly a best way, but wee need more time for investigation.

Comment 7 Lukáš Nykrýn 2015-04-21 13:51:09 UTC
This should be now fixed with the rebase.

Comment 10 errata-xmlrpc 2015-11-19 14:57:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2092.html


Note You need to log in before you can comment on or make changes to this bug.