Bug 11263 - IP, Routing, address assignment
IP, Routing, address assignment
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: netkit-base (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-06 06:14 EDT by dave
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-15 08:03:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dave 2000-05-06 06:14:41 EDT
Hey Hi there. 8-)

OK let me try explain this one...Basically it goes as follows:
I had a fresh install of RedHat (gnome wkst), I assigned an IP
address/DNS/Gateway to it during install. I rebooted and everything was
beautiful! I then moved the PC to another network from a
196.33.40.11/255.255.255.0 IP with a gateway of 196.33.40.125; to a
10.0.0.253/255.255.255.0 IP and a gateway of 10.0.0.254. It worked fine
until after about 2 days the PC could not ping itself (10.0.0.253) or
anything on it's local LAN (10.0.0.0), BUT other PC's could ping it??
After finding this and after much playing around discovered that if the
default gateway of 10.0.0.254 was removed then it would work perfectly, I
even tried changing the gateway to 10.0.0.1, So basically whenever a
default gateway was assigned the interface sorta just stopped working.
Really weird huh ? I reinstalled RedHat 6.2 and it worked fine, until I
changed the IP and Default Gateway again using NETCONF (console mode).

That was on one PC, on another PC I had a different hassle which goes as
follows:
I assigned 10.0.0.1/255.255.255.0 during install to the LAN card, all
worked well, until I needed to change the IP temporarily I used the
follwing set of commands:
ifconfig eth0 down
ifconfig eth0 10.0.0.253 netmask 255.255.255.0

OK the interface came up and worked perfectly, for about 5mins then died
(ie could not ping anywhere from it or to it), I repeated the exercise
numerous times and still the same hassle...
Sheeez what a mouth full! lol
Anyways I have 3 years experience in Networking, I'm an MCSE *bleh*, have
been working with Cisco routers/Linux/FreeBSD for 2 years and have never
seen anything like this.
I'm quite willing to accept that I've made a mistake somewhere in which
case I would be really keen to hear where...8-)
Oh yea the Module name for the LAN cards, first PC "eepro" (intel
Eepro100), second PC "rtl8139".However i did try changing LAN cards in Both
Pc's but it had no effect on the problem. I also double checked for
confilcts etc...but found none...

Also on Both PC's I have deleted RedHat 6.2 and gone back to RedHat 6.0
which is now working absolutely 100%
8-)

Kindest regards
Dave Wilson
www.sai.co.za
Comment 1 Jeff Johnson 2000-05-10 14:02:59 EDT
The failure after 5 minutes of an otherwise working component seems to
indicate that you may have to track some time dependent part of the environment,
like DHCP lease expiry, arp cache timeout (with failure to perform associated
redirect), DNS record timeouts, or even intermittent hardware failure due to
transient heating.
Comment 2 Jeff Johnson 2000-05-15 08:03:59 EDT
I'm not going to be able to diagnose the two problems without seeing
the routing table (netstat -rn)  and interface configuration (ifconfig -a)
before and after the problem, so I'm gonna close this bug. Feel free to
reopen the bug (but please supply the requested information) if you want
me to try to understand the cause of the probles.

Note You need to log in before you can comment on or make changes to this bug.