Bug 1126302 - Remove "DeprecationWarning" message when virt-who run at non-background mode
Summary: Remove "DeprecationWarning" message when virt-who run at non-background mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who
Version: 6.6
Hardware: x86_64
OS: All
unspecified
low
Target Milestone: rc
: ---
Assignee: Radek Novacek
QA Contact: gaoshang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 06:50 UTC by Liushihui
Modified: 2016-12-01 00:33 UTC (History)
5 users (show)

Fixed In Version: virt-who-0.10-6.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 07:13:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1513 normal SHIPPED_LIVE virt-who bug fix and enhancement update 2014-10-14 01:22:23 UTC

Description Liushihui 2014-08-04 06:50:13 UTC
Description of problem:
When virt-who run at non-background mode, on the terminal side, it will show "/usr/share/virt-who/virt/hyperv/ntlm.py:24: DeprecationWarning: the md5 module is deprecated; use hashlib instead from md5 import md5"

Version-Release number of selected component (if applicable):
subscription-manager-1.12.10-1.el6.x86_64
python-rhsm-1.12.5-1.el6.x86_64
virt-who-0.10-4.el6.noarch
katello-headpin-1.4.3.26-1.el6sam_splice.noarch
candlepin-0.9.6.4-1.el6sam.noarch

How reproducible:
Always

Steps to Reproduce:
1. Register system to SAM server
2. Configure virt-who in libvirtd mode as the following:
[root@hp-z220-03 ~]# cat /etc/sysconfig/virt-who 
    VIRTWHO_BACKGROUND=0
    VIRTWHO_DEBUG=1
    VIRTWHO_INTERVAL=5
3. Start virt-who service , check the output message on the terminal
# service virt-who restart

Actual results:
On the terminal, It will show DeprecationWarning as the following:
Stopping virt-who:                                         [FAILED]
Starting virt-who: INFO: No configurations found, using libvirt as backend
DEBUG: Starting infinite loop with 2 seconds interval
/usr/share/virt-who/virt/hyperv/ntlm.py:24: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  from md5 import md5
Creating new instance of LibvirtMonitor
DEBUG: Starting libvirt monitoring event loop

Expected results:
I suggest it needn't to show the message of "/usr/share/virt-who/virt/hyperv/ntlm.py:24: DeprecationWarning: the md5 module is deprecated; use hashlib instead from md5 import md5" on the terminal side.

Additional info:
When virt-who run at background mode, it hasn't this problem.

Comment 2 Radek Novacek 2014-08-08 09:07:10 UTC
Fixed by following upstream commit:

https://git.fedorahosted.org/cgit/virt-who.git/commit/?id=a8f50d6c5175cd481864593a28bacb7a9b6abeeb

Comment 3 Radek Novacek 2014-08-08 14:50:23 UTC
Fixed in virt-who-0.10-6.el6.

Comment 5 Liushihui 2014-08-14 08:51:58 UTC
Verified it on virt-who-0.10-6.el6.noarch

Comment 6 errata-xmlrpc 2014-10-14 07:13:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1513.html


Note You need to log in before you can comment on or make changes to this bug.