Bug 1126340 - Custom channels are not automatically synchronized during ISS
Summary: Custom channels are not automatically synchronized during ISS
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: sat570-triage
TreeView+ depends on / blocked
 
Reported: 2014-08-04 08:33 UTC by Jiří Mikulka
Modified: 2014-10-06 13:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-29 18:28:37 UTC


Attachments (Terms of Use)

Description Jiří Mikulka 2014-08-04 08:33:23 UTC
Description of problem:
Satellite-sync doesn't synchronize (already synchronized) custom channels when running satellite-sync without any channel specification.

Version-Release number of selected component (if applicable):
spacewalk-backend-2.2.43-1.el6.noarch (Satellite 5.7 / Spacewalk 2.2)

How reproducible:
always

Steps to Reproduce:
1. setup master with some custom channels, setup slave with no channels
2. setup ISS master -> slave
3. on ISS slave, satellite-sync all ISS master custom channels
   $ satellite-sync -c <custom_channel_1> -c <custom_channel_2> ...
4. on ISS master, push some packages in custom channel 1
5. on ISS slave run "satellite-sync" with no options/parameters

Actual results:
# satellite-sync 
ERROR: No channels currently imported; try satellite-sync --list-channels; then satellite-sync -c chn0 -c chn1...

Expected results:
new packages in already synchronized custom channels are synchronized

Additional info:

Comment 1 Stephen Herr 2014-09-29 18:28:37 UTC
Not a bug. Custom channels are never synced unless you explicitly specify the channel label with -c / --channels or add the the --include-custom-channels option to the naked satellite-sync command. This is documented in the man page.


Note You need to log in before you can comment on or make changes to this bug.