Bug 1126347 - RFE: php54-php-pecl-redis php54-php-pecl-igbinary
Summary: RFE: php54-php-pecl-redis php54-php-pecl-igbinary
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: distribution
Version: php54
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 2.0
Assignee: Brian Gollaher
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 08:55 UTC by Christophe Augello
Modified: 2018-12-09 18:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-25 13:42:42 UTC


Attachments (Terms of Use)

Description Christophe Augello 2014-08-04 08:55:10 UTC
1. Proposed title of this feature request  
  RFE: php54-php-pecl-redis php54-php-pecl-igbinary 

2. Who is the customer behind the request?  
Account: 1004746
TAM customer: no
SRM customer: no
Strategic: no
  
3. What is the nature and description of the request?  
  Request of 2 packages in a supported Red Hat channel

4. Why does the customer need this? (List the business requirements here)  
  Customer needs the packages in a supported Red Hat Channel

Business need

5. How would the customer like to achieve this? (List the functional requirements here)  
  N/A
6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  
N/A
  
7. Is there already an existing RFE upstream or in Red Hat Bugzilla?  
  No
8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?  

RHEL 6
  
9. Is the sales team involved in this request and do they have any additional input?  

No
  
10. List any affected packages or components.
  
php54-php-pecl-redis php54-php-pecl-igbinary 
  
11. Would the customer be able to assist in testing this functionality if implemented?  

Yes

Comment 1 Remi Collet 2014-08-04 09:02:59 UTC
Those packages exists in EPEL for base packages and, for RHSCL 1.1, in
https://www.softwarecollections.org/en/scls/remi/php54more/


pecl-igbinary is probably not suitable for a stable distribution, as this extension is not maintained upstream (fedora package are a git snapshot + patches).

pec/igbinary also optionally requires pecl/apcu.

pecl/igbinary is optional for pecl/redis


nrk/Predis is a pure PHP implementation of redis client.


redis (server) is not in RHEL.

Comment 4 Joe Orton 2014-11-25 13:42:42 UTC
Per comment 1, the "igbinary" and "redis" extensions are not considered stable, maintained upstream projects currently suitable for inclusion in Red Hat Software Collections.  There is no intent to add these packages at this time.


Note You need to log in before you can comment on or make changes to this bug.