Bug 1126349 - FreeBSD 9.2 installation freeze after start
Summary: FreeBSD 9.2 installation freeze after start
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: All
OS: FreeBSD
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Vinzenz Feenstra [evilissimo]
QA Contact: Lukas Svaty
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 09:04 UTC by Lukas Svaty
Modified: 2016-02-10 19:48 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-02 11:47:57 UTC
oVirt Team: Virt


Attachments (Terms of Use)
engine log (10.18 KB, text/x-log)
2014-08-07 10:20 UTC, Lukas Svaty
no flags Details
libvirt log (223.62 KB, text/x-log)
2014-08-07 10:20 UTC, Lukas Svaty
no flags Details
qemu log of test01 vm (3.02 KB, text/x-log)
2014-08-07 10:21 UTC, Lukas Svaty
no flags Details
vdsm log (10.78 KB, text/x-log)
2014-08-07 10:21 UTC, Lukas Svaty
no flags Details

Description Lukas Svaty 2014-08-04 09:04:16 UTC
Description of problem:
As we have FreeBSD9.2 in VM Operation Systems list, the boot of FreeBSD9.2 should work. However it freezes right after start of installation after boot menu:

FreeBSD-9.2-RELEASE-amd64-bootonly.iso:
~~~
Booting...
/
~~~

FreeBSD-9.2-RELEASE-i386-bootonly.iso:
FreeBSD/x86 bootstrap loader, Revision 1.1
(root@bake.isc.freebsd.org, Fri Sep 27 03:22:55 UTC 2013)
pxe_open: server addr: *****************
pxe_open: server path: /
pxe_open: gateway ip: ***************
/

Version-Release number of selected component (if applicable):
ovirt-3.5.0-beta2
host:
qemu-img-0.12.1.2-2.355.el6_4.9.x86_64
gpxe-roms-qemu-0.9.7-6.10.el6.noarch
qemu-kvm-0.12.1.2-2.355.el6_4.9.x86_64
libvirt-lock-sanlock-0.10.2-29.el6_5.9.x86_64
libvirt-client-0.10.2-29.el6_5.9.x86_64
libvirt-0.10.2-29.el6_5.9.x86_64
libvirt-python-0.10.2-29.el6_5.9.x86_64
[root@dell-r210ii-12 ~]#

How reproducible:


Steps to Reproduce:
1. try to install FreeBSD9.2 into VM

Actual results:
Installation stuck after bootmenu

Expected results:
FreeBSD9.2 should be functional as we support it in VM Operation Systems

Comment 1 Omer Frenkel 2014-08-05 05:44:19 UTC
what is the status of the vm in the webadmin?
please attach engine+vdsm+libvirt+qemu logs

Comment 2 Michal Skrivanek 2014-08-06 11:23:40 UTC
what about virtio console setting in Edit VM?

Comment 3 Lukas Svaty 2014-08-07 10:19:46 UTC
status of VM: Powering Up -> Up
adding vdsm, qemu, libvirt, engine logs
VM options, standard VM without any change in options (except name, disk, network) -> Virtio Console Disabled

Comment 4 Lukas Svaty 2014-08-07 10:20:10 UTC
Created attachment 924862 [details]
engine log

Comment 5 Lukas Svaty 2014-08-07 10:20:39 UTC
Created attachment 924863 [details]
libvirt log

Comment 6 Lukas Svaty 2014-08-07 10:21:16 UTC
Created attachment 924864 [details]
qemu log of test01 vm

Comment 7 Lukas Svaty 2014-08-07 10:21:36 UTC
Created attachment 924865 [details]
vdsm log

Comment 8 Lukas Svaty 2014-08-07 10:47:48 UTC
after conversation with dev

possible problems:
1. PXE boot
2. 32bit iso (instead of Vinzenzs 64bit)

Comment 9 Vinzenz Feenstra [evilissimo] 2014-08-18 07:17:26 UTC
Lukas please check whether or not you could figure out if this is a problem of the PXE boot. From what I can tell, there's no indication that this is a problem of devices or any settings we can tune. It rather seems to be a problem of PXE boot.
So please test if your PXE boot setup for FreeBSD works with a VM created for instance with Virt Manager.

Comment 10 Vinzenz Feenstra [evilissimo] 2014-09-01 13:39:15 UTC
@Lukas: please update your investigation results here:

Comment 11 Lukas Svaty 2014-09-02 11:43:33 UTC
Tried PXE boot on local machine / Virtual via virt-manager
Seems the problem is in PXE boot of FreeBSD 9.2.

Also tried booting from iso via iso domain and it works for 32 and 64bit system.

PXE boot cfg:
label FreeBSD9.2
    menu label ^FreeBSD9.2-i386 
    pxe path/to/image/FreeBSD9.2/boot/pxeboot

Comment 12 Vinzenz Feenstra [evilissimo] 2014-09-02 11:47:57 UTC
Closing since this is not a issue of RHEV and seems to be a problem specific to the PXE boost code used in fbsd

Comment 13 Lukas Svaty 2014-09-02 12:38:23 UTC
seems the bug is on FreeBSD side and is being investigated

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=189212

Comment 14 Sven Kieske 2014-09-12 07:56:47 UTC
It would be cool if you can add this information to the freebsd bug report
because it looks like it will get closed otherwise.
There is information that this is indeed a bug in ISC-DHCP?


Note You need to log in before you can comment on or make changes to this bug.