Bug 112640 - dcraw - request fo enhancement to gimp for better digital camera support (code provided)
dcraw - request fo enhancement to gimp for better digital camera support (cod...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
http://www.cybercom.net/~dcoffin/dcra...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-25 14:15 EST by Bryce
Modified: 2014-03-16 22:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-17 06:00:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryce 2003-12-25 14:15:57 EST
Description of problem:

One of the annoyances with digital cameras these days is that many are
starting to move away from writing GIF or JPG formats directly to the
memory cards, instead prefering to go down the RAW image route. At
present in the Fedora Core dist, there's nothing to help facilitate
this and people are coerced into running windows to convert the images
into something manageable.

Fortunately someone out there has done significant and impressive work
on this issue, in the form of dcraw by Dave Coffin. I've looked at the
licencing and it appears to be compatible with OSS

At a personal level I use a Sigma SD9 and this conversion utility does
work quite well with it. It may not be as pollished as the windows
conversion tools but it's sufficent.
Note that the list of cameras supported is 80+ so well worth adding
the support.

Cheers

Phil (aka bryce (ex RHAT))
=--=

Additional info:
From: http://www.cybercom.net/~dcoffin/dcraw/index.html

dcraw.c -- Convert raw photos to PPM
Supports 86 cameras at last count. Compile with "gcc -o dcraw -O3
dcraw.c -lm". Run with no arguments to see a usage message. (For
fedora core use you may need to uncomment the ushort typedef on line 54)

rawphoto.c -- GIMP plugin to load raw photos
After installing "dcraw", do "gimptool --install rawphoto.c". Now the
GIMP can load raw photos without creating a PPM file.
Comment 1 Nils Philippsen 2004-02-21 11:33:55 EST
Hi Bryce, how's it going?

Sorry for the lag -- I'm maintaining the gimp package since a while
and some stuff was assigned to Matt Wilson. I'll change the component
to distribution as it really belongs there (new package).

I also don't have any digital camera to test this with ;-).
Comment 2 Need Real Name 2004-05-08 14:44:27 EDT
I also vote for this.

I don't know if dcraw et. al belongs with GIMP (maybe that is an
upstream decision for the GIMP folks), but there is definitely an
opportunity for a "digital-photo-tools" package.  It should have the
dcraw programs and also some or all of the tools listed on this page:

  http://bugbear.blackfish.org.uk/~bruno/panorama-tools/

If I could choose only one additional tool, it would be this one:

  http://www.sentex.net/~mwandel/jhead/
Comment 3 Nils Philippsen 2004-05-10 03:15:24 EDT
"9pcgvl502", please open individual RFEs for these others.

Bill, putting dcraw and the plugin into upcoming FC3 seems a good idea
to me for owners of cameras that can produce raw images. What do you
think?
Comment 4 Bill Nottingham 2004-05-19 16:55:18 EDT
Sure, go for it.
Comment 5 Bill Nottingham 2004-05-19 16:55:53 EDT
Although, it really sounds like the pluging should go in upstream gimp. :)
Comment 6 Ashley Gittins 2004-11-22 12:22:50 EST
If you are going to consider bringing RAW file support into the gimp 
distributed with FC, may I suggest looking at <a 
href="http://www.aei.mpg.de/~udif/UFRaw/">http://www.aei.mpg.de/~udif/UFRaw/</a> 
instead, I am using it with my Fuji S7000 and FC2 on x86_64 and 
finding it to give good results. It uses the dcraw code, works with 
the same cameras (presumably) and is GPL'd. That said though, I would 
lean towards Bill's opinion in that it should probably be brought in 
upstream rather than at distro-level, but if something is going to be 
brought in, I think UFRaw has the best interface out there. 
 
I agree with an earlier comment about including some pano tools, but 
that's probably a separate RFE. 
Comment 7 Nils Philippsen 2004-12-17 06:00:42 EST
Both dcraw and the ufraw plugin are in current Rawhide. Please
consider opening _separate_ RFEs for other plugins but as I see it
they should probably go into Fedora Extras.

Note You need to log in before you can comment on or make changes to this bug.