Bug 1126404 - subscription-manager-migration reports Systems Engine in CLI and not Satellite 6
Summary: subscription-manager-migration reports Systems Engine in CLI and not Satellite 6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data
Version: 6.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-08-04 10:51 UTC by Rich Jerrido
Modified: 2014-10-14 07:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no documentation required
Clone Of:
Environment:
Last Closed: 2014-10-14 07:48:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description Rich Jerrido 2014-08-04 10:51:37 UTC
Description of problem:
When using subscription-manager-migration to migrate a system from Sat 5.x to Sat 6.x, rhn-migrate-classic-to-rhsm asks for the username/password of 'Systems Engine'. This should be changed to 'Satellite 6'

Version-Release number of selected component (if applicable):
subscription-manager-1.8.22-1.el5
subscription-manager-migration-1.8.22-1.el5
subscription-manager-migration-data-1.11.3.2-1.el5


How reproducible:
100%

Steps to Reproduce:
1. install subscription manager packages (yum install subscription-manager{,-migration*})
2. Install katello consumer RPM. (rpm -Uvh http://<your satellite6>/pub/katello-ca-consumer-latest.noarch.rpm

3. run rhn-migrate-classic-to-rhsm

Actual results:
User is prompted for 'Systems Engine' username. 
[root@localhost ~]# rhn-migrate-classic-to-rhsm 
Red Hat account: admin
Password: 
System Engine Username: admin
Password: 
Environment: Library

Expected results:

User should be prompted for Satellite 6 username.

Comment 2 Bryan Kearney 2014-08-06 18:57:45 UTC
This was fixed by

commit 767f9a8ad6041ab6b0f251f61bb6927f1f96df89
Author: Alex Wood <awood@redhat.com>
Date:   Thu Sep 19 15:13:33 2013 -0400

    Refactor credentials gathering.
    
    Additionally, use a more generic term that "System Engine".

Comment 3 John Sefler 2014-08-12 18:03:32 UTC
This bug was addressed in bug 912375.

The credential labels were changed to "Subscription Service", a generic value (no longer System Engine and not Satellite).

This fix will be delivered with the RHEL 6.6 release which will include subscription-manager-migration-1.12.


Verifying....
[root@jsefler-6 ~]# rpm -q subscription-manager-migration
subscription-manager-migration-1.12.10-1.el6.x86_64

[root@jsefler-6 ~]# subscription-manager unregister
This system is currently not registered.
[root@jsefler-6 ~]# rhn-migrate-classic-to-rhsm --serverurl=foobar.com
Red Hat username: foo   
Red Hat password: 
Subscription Service username: bar
Subscription Service password: 
Unable to connect to certificate server: Invalid credentials..  See /var/log/rhsm/rhsm.log for more details.
[root@jsefler-6 ~]# 

VERIFIED: Notice the generic "Subscription Service" label used to prompt for credentials that will be passed to the subscription server.

Comment 4 errata-xmlrpc 2014-10-14 07:48:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.