Bug 1126433 - Config file /usr/share/cacti/include/config.php is not marked as a config file in rpm
Summary: Config file /usr/share/cacti/include/config.php is not marked as a config fil...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: cacti
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 12:41 UTC by Trevor Hemsley
Modified: 2014-09-11 17:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 17:02:57 UTC


Attachments (Terms of Use)

Description Trevor Hemsley 2014-08-04 12:41:55 UTC
Description of problem:
The cacti config file in /usr/share/cacti/include/config.php is not marked as a config file in the rpm so every update replaces it and breaks systems where the user/password for the database is changed from the default

Version-Release number of selected component (if applicable):
0.8.8b

How reproducible:
Always

Steps to Reproduce:
1. Install cacti from EPEL6
2. Amend /usr/share/cacti/include/config.php to reflect your own db username etc
3. Wait for a yum update to come along and cacti stops working

Actual results:
File is replaced on yum update cacti

Expected results:
File should be marked as config so it is not replaced

Additional info:

Comment 1 Ken Dreyer 2014-09-11 17:02:57 UTC
Hi Trevor, thanks very much for the bug report.

In a traditional upstream tarball you'd typically edit the config.php file, but the Red Hat package works slightly differently. You should be updating /etc/cacti/db.php instead. That file is indeed marked as noreplace in the RPM.

You can find out more information about the Red Hat package by reading the file at /usr/share/doc/cacti-*/docs/README.fedora.

Since the expectation is that you'd edit /etc/cacti/db.php instead, I'm going to consider this issue resolved. Please re-open if you disagree. Thanks again for your contribution and thanks for using the package.


Note You need to log in before you can comment on or make changes to this bug.