Bug 1126462 - When looking at puppet-modules, empty Description == "null"
Summary: When looking at puppet-modules, empty Description == "null"
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 13:29 UTC by Grant Gainey
Modified: 2015-12-03 17:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-27 19:59:29 UTC


Attachments (Terms of Use)

Description Grant Gainey 2014-08-04 13:29:51 UTC
Description of problem:

If you have uploaded a puppet-module without a description-field into sat6, and then go look at it, the Description field contains 'null'

Version-Release number of selected component (if applicable):
6.0.4

How reproducible:

1. Create a puppet-module
2. Upload it into a puppet-repository using 

  hammer repository upload-content --id #{repo['id']} --path #{built_module_path}
  
3. Go look at that repository
4. Choose the puppet-module
5. Look at "Description"
6. Be sad

Actual results:
Description-null

Expected results:
Should either have a description (if one was available) or empty space if there is not one

Comment 2 Brad Buckingham 2015-08-27 19:16:49 UTC
Updated an existing puppet module (theforeman-git-1.3.0.tar.gz) to remove the Description from the Modulefile & metadata.json.  I imported that module using the UI and then looked at the module using the CLI.  The CLI output for Description is 'blank' versus 'null'.

Going to move to ON_QA for verification.

hammer> puppet-module info --id 0ac5406e-b715-425f-9e13-3a0aec1dda20
ID:             0ac5406e-b715-425f-9e13-3a0aec1dda20
Name:           git
Version:        1.3.0
Author:         theforeman
Summary:        git installation and configuration
Description:    
License:        GPLv3+
Project Page:   http://github.com/theforeman/foreman-installer
Source:         git://github.com/theforeman/puppet-git
Dependencies:   

File checksums: 
    d4a0411c05e060dfdc8069558825d5b7  manifests/params.pp
    9eef91148a9b14ec7f9df333daebc746  LICENSE
    42b7675afc5206424d845c406ee26e2c  Modulefile
    8fd6e4f326d1b0f92031f25780c9d3b9  manifests/install.pp
    7e1d425ae40e374258614183a9ccac8f  manifests/init.pp
    c218a4251ae3bcd32280b2fe02473349  manifests/repo.pp
    b38a17813ef4bb603579835cf7a2932a  README.md
Tag List:       
Repositories:   
 1) Id:   12
    Name: puppet

hammer>

Comment 3 Grant Gainey 2015-08-27 19:24:41 UTC
The 'null' I was reporting was specifically in the web-UI - is the description now empty (as opposed to the string 'null') there as well?

Comment 4 Brad Buckingham 2015-08-27 19:59:29 UTC
I chatted with Grant and the issue was observed on Content -> Content Search.  I confirmed the same on my Satellite 6.1.1 GA install.

The Content Search page has been removed in the upstream; therefore, when the code is rebased for Satellite 6.2, the issue will no longer be observed.  We have agreed to close this BZ, since the issue will not be observed in future releases.


Note You need to log in before you can comment on or make changes to this bug.