Bug 112651 - AbiWord (2.0.2) crashes
Summary: AbiWord (2.0.2) crashes
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: abiword   
(Show other bugs)
Version: 1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-26 13:22 UTC by Tony Pattison
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-16 08:36:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tony Pattison 2003-12-26 13:22:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
when using AbiWord in Fedora core 1 (kernel 2.4.22-1.2115.nptl) :-
1) I open (import) a RTF file
2) I cut a number of lines, I create a nuew document
3) I paste the lines into the new document
4) I save the new document as a text (txt) file, I close the new
document's window down
6) Sometime the crash happens then, sometimes I have to repeat the
"cut,create,paste,save as" sequence a couple of times before it crashes.
7) The X error message says "Applicate "AbiWord" (process 2073) has
crashed due to a fatal error. (Aborted)"

Version-Release number of selected component (if applicable):
abiword-2.0.2-1

How reproducible:
Always

Steps to Reproduce:
1.Cut and paste into newly created doc
2.Save doc as TXT file
3.Close down doc's window
    

Actual Results:  X Error message

Expected Results:  Nothing

Additional info:

Comment 1 Jeremy Katz 2004-01-03 20:12:25 UTC
Can you attach to the abiword process with gdb and then get a
backtrace of when it aborts?

Comment 2 Tony Pattison 2004-01-04 15:26:22 UTC
The following was printed in the gdb terminal window:-

Program received SIGSEGV,Segmentation Fault.
[Switching to Thread - 1085353856 (LWP 2021)]

And a "bt" command gave :-
0x00000000 in ?? ()


I hope this helps.
Tony

Comment 3 Caolan McNamara 2004-06-16 08:36:50 UTC
I can't reproduce this with abiword 2.0.7-1 :-(. It could be fixed in
a later release than 2.0.2, or might be something to do with a
specific font or locale. Can you try with a later version (FC2), and
if it still persists attach a sample document which causes the crash
when cut and paste from.


Note You need to log in before you can comment on or make changes to this bug.