Bug 1126525 - [AMQP 1.0] Can't read content endoding property
Summary: [AMQP 1.0] Can't read content endoding property
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: 3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: 3.1
: ---
Assignee: Gordon Sim
QA Contact: Petr Matousek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 15:55 UTC by Gordon Sim
Modified: 2015-04-14 13:48 UTC (History)
3 users (show)

Fixed In Version: qpid-cpp-0.30-2
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-14 13:48:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Apache JIRA QPID-5959 0 None None None Never
Red Hat Bugzilla 975444 0 high CLOSED provide access to all properties in an AMQP 1.0 message 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1045091 0 unspecified CLOSED [amqp1.0] x-amqp-absolute-expiry-time, x-amqp-creation-time missing in the received message properties map 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1059786 0 medium CLOSED [amqp1.0] missing first-acquirer property support 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHEA-2015:0805 0 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.1 Release 2015-04-14 17:45:54 UTC

Internal Links: 975444 1045091 1059786

Description Gordon Sim 2014-08-04 15:55:36 UTC
Description of problem:

There is no way to get at the AMQP 1.0 content encoding field via qpid::messaging

Version-Release number of selected component (if applicable):

3.0

How reproducible:

100%

Steps to Reproduce:
1. Send a message with content encoding in it (e.g. using qpid::messaging with 1.0 add a property x-amqp-content-encoding)
2. Receive the message and check for x-amqp-content-encoding property

Actual results:

No such property is reported as present

Expected results:

The property in the encoded message should be returned to the application

Additional info:

Comment 1 Gordon Sim 2014-08-04 17:32:42 UTC
Fixed upstream: https://svn.apache.org/r1615699

Comment 3 Petr Matousek 2014-12-12 10:52:45 UTC
AMQP 1.0 content encoding now accessible via x-amqp-content-encoding message field in qpid::messaging API.

Verified on rhel6.6 (x86_64 and i386)

Packages:
qpid-cpp-*-0.30-4

-> VERIFIED

Comment 5 errata-xmlrpc 2015-04-14 13:48:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0805.html


Note You need to log in before you can comment on or make changes to this bug.