Bug 1126531 - NPE on Cold move disk operation
Summary: NPE on Cold move disk operation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Ravi Nori
QA Contact: Jiri Belka
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 16:24 UTC by Ori Gofen
Modified: 2016-05-26 01:49 UTC (History)
12 users (show)

Fixed In Version: ovirt-3.5.0_rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:37:04 UTC
oVirt Team: Infra


Attachments (Terms of Use)
vdsm+engine logs (960.12 KB, application/gzip)
2014-08-04 16:24 UTC, Ori Gofen
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 32358 master MERGED core: trailing spaces removed from dstSdUUID Never
oVirt gerrit 32359 ovirt-engine-3.5 MERGED core: trailing spaces removed from dstSdUUID Never

Description Ori Gofen 2014-08-04 16:24:06 UTC
Created attachment 923950 [details]
vdsm+engine logs

Description of problem:
engine throws NPE when cold moving disk from one domain to another.

2014-08-04 19:20:19,523 ERROR [org.ovirt.engine.core.bll.tasks.CommandAsyncTask] (org.ovirt.thread.pool-8-thread-14) [within thread]: endAction for action type Unknown threw an exception.: java.lang.NullPointerException
        at org.ovirt.engine.core.bll.tasks.CoCoAsyncTaskHelper.endAction(CoCoAsyncTaskHelper.java:316) [bll.jar:]
        at org.ovirt.engine.core.bll.tasks.CommandCoordinatorImpl.endAction(CommandCoordinatorImpl.java:332) [bll.jar:]
        at org.ovirt.engine.core.bll.tasks.CommandAsyncTask.EndCommandAction(CommandAsyncTask.java:149) [bll.jar:]
        at org.ovirt.engine.core.bll.tasks.CommandAsyncTask.access$000(CommandAsyncTask.java:28) [bll.jar:]
        at org.ovirt.engine.core.bll.tasks.CommandAsyncTask$1.run(CommandAsyncTask.java:109) [bll.jar:]
        at org.ovirt.engine.core.utils.threadpool.ThreadPoolUtil$InternalWrapperRunnable.run(ThreadPoolUtil.java:90) [utils.jar:]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) [rt.jar:1.7.0_65]
        at java.util.concurrent.FutureTask.run(FutureTask.java:262) [rt.jar:1.7.0_65]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_65]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_65]
        at java.lang.Thread.run(Thread.java:745) [rt.jar:1.7.0_65]


Version-Release number of selected component (if applicable):
beta.2

How reproducible:
100%

Steps to Reproduce:
1.create vm +disk
2.move disk while vm is down

Actual results:
engine throws several exceptions among them NPE

Expected results:


Additional info:

Comment 1 Tal Nisan 2014-08-05 08:37:06 UTC
Yair, it seems related to the context change, can you have a look?

Comment 2 Allon Mureinik 2014-08-05 11:26:16 UTC
Hmmm...

2014-08-04 19:20:19,523 ERROR [org.ovirt.engine.core.bll.tasks.CommandAsyncTask] (org.ovirt.thread.pool-8-thread-14) [within thread]: endAction for action type Unknown threw an exception.: java.lang.NullPointerException

Why is the action type "Unknown"?

Comment 3 Allon Mureinik 2014-08-26 17:21:11 UTC
(In reply to Tal Nisan from comment #1)
> Yair, it seems related to the context change, can you have a look?

Moving to Yair in order to determine if this is a CoCo issue or not.

Comment 4 Yair Zaslavsky 2014-08-27 01:21:30 UTC
Ravi ,please take a look, thanks.

Comment 5 Piotr Kliczewski 2014-09-03 06:59:34 UTC
Please provide earlier vdsm logs

Comment 6 Ori Gofen 2014-09-03 10:20:49 UTC
Piotr,unfortunately those have been wiped out of the cycle.
reproducing this one is quite a challenging due to the fact that ,it seems,the main issue has little to do with the cold move operation.
I guess I should have paid more attention...

Comment 7 Jiri Belka 2014-09-17 11:46:31 UTC
Are verification steps useful, especially as #6 states that reproducing this issue is quite challenging...? Also the diff is just about deleting white space. Thx.

Comment 8 Ravi Nori 2014-09-17 12:51:20 UTC
If cold move of disk works, this can be marked as verified.

Comment 9 Jiri Belka 2014-09-19 07:19:14 UTC
ok, verified based on #8.

ovirt-engine-backend-3.5.0-0.0.master.20140911085455.gite1c5ffd.el6.noarch

Comment 10 Sandro Bonazzola 2014-10-17 12:37:04 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.