Bug 1126532 - [RFE] Assign seperate compute nodes for separate projects?
Summary: [RFE] Assign seperate compute nodes for separate projects?
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 4.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Sylvain Bauza
QA Contact: Shai Revivo
URL:
Whiteboard:
: 1204979 (view as bug list)
Depends On:
Blocks: 1154162
TreeView+ depends on / blocked
 
Reported: 2014-08-04 16:30 UTC by Sadique Puthen
Modified: 2019-09-09 15:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-05 17:08:36 UTC


Attachments (Terms of Use)

Description Sadique Puthen 2014-08-04 16:30:13 UTC
Description of problem:

customer would like to assign dedicated compute node for specific projects .So, every VM of that project should scheduled on that compute node.

Eg, We have three compute nodes A, B, C & two tenants TenA, TenB.

Our requirement is to schedule TenA Vms  onto Node A and all other tenants(TenB etc) VM can go either on B or C node. A reserve for particular tenants.

There is a blueprint started upstream to make this possible. https://blueprints.launchpad.net/nova/+spec/whole-host-allocation

Once this is done, customer would like this to be included in RHEL-OSP release.

Comment 1 Sylvain Bauza 2014-08-22 17:42:17 UTC
I just discussed upstream with the owner of whole-host-allocation (Phil Day), he will provide two specs for Kilo, one for dedicating hosts and one for pclouds idea.

On my side, I'll discuss with Belmiro from CERN to see when he wants to do https://review.openstack.org/99476. If not, I'll provide by myself the patch for Kilo (it should be easy to backport to Juno if so)

There are also 2 patches upstream for the same thing, but I disagree with the implementation :
https://review.openstack.org/116194
https://review.openstack.org/115824


All of this work will be happen on Kilo anyway.

Comment 5 Sylvain Bauza 2016-04-12 14:32:28 UTC
No clear sign of life yet. Belmiro was wanting to work on it by Kilo (as I said earlier) but it seems he left that out finally.

Comment 8 Stephen Gordon 2017-01-24 21:37:52 UTC
*** Bug 1204979 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.