Bug 1126547 - webadmin [TEXT]: misleading error message when attempting IDE hotplug
Summary: webadmin [TEXT]: misleading error message when attempting IDE hotplug
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: m1
: 3.6.0
Assignee: Idan Shaby
QA Contact: Ori Gofen
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 17:53 UTC by Ori Gofen
Modified: 2016-03-10 06:14 UTC (History)
12 users (show)

Fixed In Version: ovirt-engine-3.6.0-0.0.master.20150412172306.git55ba764
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-04 11:23:24 UTC
oVirt Team: Storage


Attachments (Terms of Use)
image (17.83 KB, image/png)
2014-08-04 17:53 UTC, Ori Gofen
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 35467 master MERGED core: New Error Message for an IDE Hot Plug Never

Description Ori Gofen 2014-08-04 17:53:01 UTC
Created attachment 923980 [details]
image

Description of problem:
When attempting to live attach an IDE disk oVirt prompts a popup error message:
"Cannot attach Virtual Machine Disk. Guest OS version is not supported."(see image)
according to docs ( http://www.linux-kvm.org/page/Hotadd_pci_devices#Add_a_disk )
IDE disks are not hotpluggable so there isn't any os version that do supports this action.
Version-Release number of selected component (if applicable):
beta.2

How reproducible:
100%

Steps to Reproduce:
1.hotplug IDE disk
2.
3.

Actual results:
misleading message 

Expected results:
message should be something like:
Cannot attach Virtual Machine Disk,IDE disks do not support hotplug

Additional info:

Comment 1 lkuchlan 2015-04-19 09:49:56 UTC
Tested using ovirt-engine-3.6.0-0.0.master.20150412172306.git55ba764

There is no error message at all

Comment 2 Allon Mureinik 2015-04-19 10:56:08 UTC
Idan, can you please check this?

Comment 3 Idan Shaby 2015-05-14 12:12:19 UTC
Works for me on master - 21547f64b43bb2e3ced4faa26adda043cf736ab7.

Comment 4 Allon Mureinik 2015-05-17 10:54:01 UTC
(In reply to Idan Shaby from comment #3)
> Works for me on master - 21547f64b43bb2e3ced4faa26adda043cf736ab7.
So either the test described above if different than what you tried, or one of you is using a build he did not intend to.
Moving back to ON_QA to verify.

Ori - can you please supply the exact steps to reproduce so we can see if your scenario and Idan's are equivalent?

Comment 5 Ori Gofen 2015-05-18 12:09:14 UTC
steps:have an ide floating disk and a vm
- run the vm
- while up, attach the ide disk

Comment 6 lkuchlan 2015-05-20 08:52:16 UTC
Tested using ovirt-engine-3.6.0-0.0.master.20150412172306.git55ba764.el6

Comment 7 Sandro Bonazzola 2015-11-04 11:23:24 UTC
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.


Note You need to log in before you can comment on or make changes to this bug.