Bug 1126651 - Rule attributes under "RuleSet" in spreadsheet affects package wide
Summary: Rule attributes under "RuleSet" in spreadsheet affects package wide
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: Documentation
Version: 6.0.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Vikram Goyal
QA Contact: Lukáš Petrovický
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 01:51 UTC by Toshiya Kobayashi
Modified: 2018-12-06 17:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-12 06:42:09 UTC
Type: Bug


Attachments (Terms of Use)
Drools6Ex27_spreadsheet_package_wide_attributes.zip (578.40 KB, application/zip)
2014-08-05 02:42 UTC, Toshiya Kobayashi
no flags Details

Description Toshiya Kobayashi 2014-08-05 01:51:54 UTC
Description of problem:

If we have multiple spreadsheets in the same package and one spreadsheet configures rule attributes under "RuleSet", those attributes are applied to package wide (not only for the one spreadsheet against user's instincts) so they are effective to the other spreadsheets.


Steps to Reproduce:

# I would write a unit test once it is certified as a bug.

1. Unzip attached Drools6Ex27_spreadsheet_package_wide_attributes.zip, which includes 3 spreadsheet and 1 DRL (only hello2.xls contains "PRIORITY 100")
2. Run DecisionTableTest

Actual results:

sampleDRL, salience = 100
HelloWorld1_12, salience = 100
HelloWorld3_11, salience = 100
HelloWorld2_12, salience = 100

Expected results:

sampleDRL, salience = 0
HelloWorld1_12, salience = 0
HelloWorld3_11, salience = 0
HelloWorld2_12, salience = 100

Comment 1 Toshiya Kobayashi 2014-08-05 01:54:21 UTC
I'm not sure if this is a bug or an expected behaviour. If this is an expected behaviour, I would change this BZ to documentation BZ in order to clarify the behaviour.

Current document doesn't clearly tell the "package wide" behaviour.
http://docs.jboss.org/drools/release/6.0.1.Final/drools-docs/html_single/index.html#d0e4379

Comment 2 Toshiya Kobayashi 2014-08-05 02:42:42 UTC
Created attachment 924065 [details]
Drools6Ex27_spreadsheet_package_wide_attributes.zip

Comment 3 Toshiya Kobayashi 2014-08-06 01:51:00 UTC
from Michael Anstis:
-----
Most "RuleSet" attributes simply build DRL for "import", "query", "function" etc statements that is then compiled into the package (and hence becomes generally available within the package).

The exceptions are "Sequential" and "EscapeQuotes" that only affect processing of individual XLS decision tables:

    Sequential = true forces generation of salience values based on row number.
    EscapeQuotes = true allows the use of double-quotation marks in field values.
-----

Comment 4 Toshiya Kobayashi 2014-08-06 05:17:49 UTC
As verified that this is not a bug, I'm changing this BZ to a documentation BZ.

Comment 5 Toshiya Kobayashi 2014-08-06 05:22:49 UTC
Sent a pull request for community docs.

https://github.com/droolsjbpm/drools/pull/368

For product docs, the location of "Important" would be above "Table 6.2. Rule attribute entries in the Rule Set area".

https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_BRMS/6.0/html-single/Development_Guide/index.html#Rule_Set_Entries1

Comment 6 Mario Fusco 2014-08-06 07:39:42 UTC
Toshiya,

I merged your PR, but be advised that you changed docs in the "wrong" place. Now all our docs are under the kie-docs folder in droolsjbpm-knowledge so I copied the same sentence also there.

https://github.com/droolsjbpm/droolsjbpm-knowledge/commit/360ca299993ec616957418e7bd638261c66cbc5b

For what I know the docs under the drools-docs folder are no longer in use, so probably we should just remove them to avoid any confusion.

Comment 7 Toshiya Kobayashi 2014-08-06 08:16:13 UTC
Oops, thank you for correction!

Comment 8 Vikram Goyal 2015-02-12 06:42:09 UTC
Sorry for the delay Toshiya. I have added the note into the Development Guide for the 6.1 release.

This can be verified here [1].

Closing this bug as I don't think this requires QA approval.

[1] http://documentation-devel.engineering.redhat.com/site/documentation/en-US/Red_Hat_JBoss_BPM_Suite/6.1/html-single/Development_Guide/index.html#Rule_Attribute_Entries_in_the_Rule_Set_Area


Note You need to log in before you can comment on or make changes to this bug.