Bug 112668 - System hangs due to severe memory leak in evolution 1.4.5
System hangs due to severe memory leak in evolution 1.4.5
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: evolution (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-27 06:29 EST by Paul Michael Reilly
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 17:18:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Michael Reilly 2003-12-27 06:29:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
Even since I started using RHEL/ES with evolution and sawfish (~2
weeks ago) I have encountered a system hang state where the system is
running but not accessible (does not respond to ANY keyboard input nor
to attempts to access the system remotely, via ssh).  After poking
around and leaving traces of the system available on remote displays,
it would now appear that evolution has a memory leak and after a day
or so it consumes the 512M of physical memory and all the swap space
leaving the system inaccessible.  The last available "top" trace
showed evolution with 63% of the memory.  From this I deduced that
there was a memory leak in evolution.  Subsequent high levels of
paging (with encumbent system slowness) tended to confirm the theory.

In evolution, I use two IMAP accounts, one of them very, very large
(huge numbers of folders containing many thousands of messages). 
Evolution handles this fairly smoothly, with the notable exception of
managing subscriptions.

Version-Release number of selected component (if applicable):
evolution-1.4.5-1

How reproducible:
Always

Steps to Reproduce:
1.Login to an X session configured to run evolution as the mail client
and sawfish 3.0 as the window manager.
2.wait about a day
3.observe system is "frozen" solid.
    

Actual Results:  Had to crash the system (power down) to clear the
condition.

Additional info:
Comment 1 Paul Michael Reilly 2003-12-27 06:34:05 EST
Please let me know if there is any additional information I might
provide that will be helpful, or if there are any patches/workarounds
I might apply.
Comment 2 Dave Malcolm 2004-05-17 21:42:17 EDT
What version of ORBit2 do you have installed?  What does "rpm -q
ORBit2" output?
Comment 3 Suzanne Hillman 2004-10-20 17:18:18 EDT
This bug has been in NEEDINFO for over 5 months. Closing. If there is more
information available, please reopen and include that information.

Note You need to log in before you can comment on or make changes to this bug.