Bug 1126708 - SELinux is preventing /usr/sbin/ldconfig from 'remove_name' accesses on the directory .
Summary: SELinux is preventing /usr/sbin/ldconfig from 'remove_name' accesses on the d...
Keywords:
Status: CLOSED DUPLICATE of bug 1126706
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:7993997533fcda7f8109c7eab8d...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 06:12 UTC by Sam K. Raju
Modified: 2014-08-05 07:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-05 07:18:56 UTC


Attachments (Terms of Use)

Description Sam K. Raju 2014-08-05 06:12:31 UTC
Description of problem:
SELinux is preventing /usr/sbin/ldconfig from 'remove_name' accesses on the directory .

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that ldconfig should be allowed remove_name access on the  directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep ldconfig /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:ldconfig_t:s0
Target Context                system_u:object_r:initrc_tmp_t:s0
Target Objects                 [ dir ]
Source                        ldconfig
Source Path                   /usr/sbin/ldconfig
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           glibc-2.18-12.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-179.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.15.7-200.fc20.x86_64 #1 SMP Mon
                              Jul 28 18:50:26 UTC 2014 x86_64 x86_64
Alert Count                   2
First Seen                    2014-08-05 10:02:12 GST
Last Seen                     2014-08-05 10:07:50 GST
Local ID                      a28fb724-85ea-44a8-9097-576252bbca48

Raw Audit Messages
type=AVC msg=audit(1407218870.815:387): avc:  denied  { remove_name } for  pid=7455 comm="ldconfig" name="ld.so.cache~" dev="sda3" ino=576901 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=dir


type=AVC msg=audit(1407218870.815:387): avc:  denied  { rename } for  pid=7455 comm="ldconfig" name="ld.so.cache~" dev="sda3" ino=576901 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file


type=SYSCALL msg=audit(1407218870.815:387): arch=x86_64 syscall=rename success=yes exit=0 a0=1c6cd00 a1=7fff87a69420 a2=7a2 a3=10 items=0 ppid=2916 pid=7455 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=ldconfig exe=/usr/sbin/ldconfig subj=system_u:system_r:ldconfig_t:s0 key=(null)

Hash: ldconfig,ldconfig_t,initrc_tmp_t,dir,remove_name

Additional info:
reporter:       libreport-2.2.3
hashmarkername: setroubleshoot
kernel:         3.15.7-200.fc20.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2014-08-05 07:18:56 UTC

*** This bug has been marked as a duplicate of bug 1126706 ***


Note You need to log in before you can comment on or make changes to this bug.