Bug 1126724 - help message for serverurl and baseurl
Summary: help message for serverurl and baseurl
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-08-05 07:20 UTC by Shwetha Kallesh
Modified: 2014-10-14 07:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: help text contained hard coded port 443. Consequence: help incorrectly displayed 443 port regardless of what the user had configured as the port. Fix: Change the help text to use 'port' instead of a hard coded 443 value. Result: User will now see hostname:port which indicates that it is to use appropriate values for both hostname and port.
Clone Of:
Environment:
Last Closed: 2014-10-14 07:48:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description Shwetha Kallesh 2014-08-05 07:20:27 UTC
Description of problem:
help message for serverurl and baseurl should be modified

Version-Release number of selected component (if applicable):
[root@dhcp-0-177 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.22-1
subscription management rules: 5.11
subscription-manager: 1.12.11-1.git.0.93a5161.el6
python-rhsm: 1.12.5-1.git.0.744254e.el6

How reproducible:


Steps to Reproduce:

[root@dhcp-0-177 ~]# subscription-manager register --help | grep url -A1
  --serverurl=SERVER_URL
                        server URL in the form of https://hostname:443/prefix
--                                                                 ^^ should be changed to port 
  --baseurl=BASE_URL    base URL for content in form of
                        https://hostname:443/prefix
                                         ^^ should be changed to port 

[root@dhcp-0-177 ~]# subscription-manager service-level --help | grep url -A1
  --serverurl=SERVER_URL
                        server URL in the form of https://hostname:443/prefix
                                                                   ^^ should be changed to port 


[root@dhcp-0-177 ~]# 


Actual results:


Expected results:


Additional info:

Comment 2 Bryan Kearney 2014-08-08 14:33:57 UTC
Fixed in 

commit ab7ee41deb2610c56ec34863e9c0e8aff47fc78b
Author: Bryan Kearney <bkearney@redhat.com>
Date:   Wed Aug 6 14:53:43 2014 -0400

    1126724: Use port instead of 443 for the url help text

Comment 4 Sharath Dwaral 2014-08-15 13:29:59 UTC
Version:

# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.23-1
subscription management rules: 5.11
subscription-manager: 1.12.12-1.el6
python-rhsm: 1.12.5-1.el6

Verification:

# subscription-manager register --help | grep url -A1
  --serverurl=SERVER_URL
                        server URL in the form of https://hostname:port/prefix
                                                                   ^^^^
  --baseurl=BASE_URL    base URL for content in form of
                        https://hostname:port/prefix
                                         ^^^^
# subscription-manager service-level --help | grep url -A1
  --serverurl=SERVER_URL
                        server URL in the form of https://hostname:port/prefix
                                                                   ^^^^

VERIFIED

Comment 5 errata-xmlrpc 2014-10-14 07:48:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.