Bug 112674 - Thinkpad T23 - return from suspend fails on Fedora kernel
Thinkpad T23 - return from suspend fails on Fedora kernel
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-27 12:08 EST by Bjorn Knutsson
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 15:53:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bjorn Knutsson 2003-12-27 12:08:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:
When suspending on IBM Thinkpad T23, machine will often not wake up
properly. It will wake up to the point where it needs to access the
disk, and at this point the system freezes. If I catch on early, I can
sometimes recover the system by requesting a BIOS hibernate-to-disk,
if I do this early. Hibernate to disk will *not* work as normal,
instead it will sit there for up to a minute before proceeding.

With ACPI, nothing works, so I set kernel parameters to use APM.

When system gets back, there are log messages saying the disk lost an
interrupt.

I can predict when the problem will occur with almost 100% confidence
by listening to the disk drive at the time of suspension. If there is
a metallic sounding "clonk", then the system will not come back out of
suspension correctly. This occurs in just over 50% of suspension attempts.

With a vanilla kernel installed, the problem never occurs, and has not
 occured ever in ~2 years of pre-Fedora use of vanilla kernels.

I have tried building my own kernel from Fedora sources, disabling
ACPI and setting it up with same parameters for APM as the vanilla
kernel, to no avail.

Version-Release number of selected component (if applicable):
All Fedora kernels tested

How reproducible:
Sometimes

Steps to Reproduce:
1. Suspend to disk, either with BIOS key, or 'apm -s'
2. Listen for noise from disk
3. Try to resume
    

Actual Results:  In >50% of attempts, the system does not come back
completely out of suspension. It will come back to the point where a
disk access is needed, and then hang.

Expected Results:  The system should resume. With a vanilla kernel,
this always happens.


Additional info:

When I catch the problem and dodge it by hibernating and then resuming
from hibernation, the following error message is in the logs:

hda: dma_timer_expiry: dma status == 0x24
hda: DMA interrupt recovery
hda: lost interrupt

(dma status varies, I've seen at least 0x04 and 0x24)

It seems that the BIOS can recover (eventually) from whatever causes
this problem, if I catch it early. If I try hibernating "late" in the
hang, it cannot hibernate and a reboot is required. I don't know if
the BIOS clears the error, or if it's cleared because hibernate to
disk actually turns the disk completely off.

With a vanilla kernel (2.4.22 or 2.4.23) similarly configured, the
problem never occurs.

The system tested on is a Thinkpad T23 with a 1.2GHz processor.
Comment 1 Eric Bourque 2003-12-29 00:27:21 EST
Not sure if this is the same problem, but in case it is related, check
out bug 112702.
Comment 2 Julian Underwood 2004-01-07 00:15:27 EST
This is true--being an IBM T23 owner myself.  As a "WORKAROUND" I will
do the following (this applies to RH8,9 and FC1 for me):
1. Log out.
2. Issue a Ctrl+Alt+F1.
3. Log in as root.
4. Issue a `apm -s`.

I am able to resume 100% of the time when I logout.  However, logging
out almost defeats the purpose of suspending (I can't have all my
windows laid out.)  However, it does save boot-up time--which is
important also.  I hope this helps the team figure out how to resolve
this problem!

--Julian
Comment 3 Levi Harper 2004-01-15 13:33:24 EST
I suspect I suffer from a similiar problem (disk spins down at
suspend, but not back up afterwards).  Things 'work' after resume
until a disk read is needed, then it's done.  I have a Thinkpad R40.

However, mine did NOT work with a variety of RH 9.0 kernels, and
worked quite well with Fedora kernels until 2.4.22-1.2149.nptl.  I've
backed off to 2.4.22-1.2140.nptl, and all seems to be well.

I'm not running ACPI (I think).  How do I tell?

--Levi
Comment 4 Godmar Back 2004-02-18 01:30:03 EST
Same problem here with 2.4.22-1.2166.nptl and 2.4.22-1.2115.nptl on a
T23.  Also tried FC2-1, which fails to suspend completely.

--Godmar
Comment 5 Godmar Back 2004-02-18 03:44:31 EST
I switched to a stock 2.4.24 kernel, the problem persists.

Could any of you share a config that's known to work with a stock kernel?
Comment 6 David Lowe 2004-02-18 09:22:41 EST
I had a similar problem for some time. My Dell Inspiron 4150 would
intermittently hang on resume from suspend with no interesting error
messages. Am using APM.

Eventually I traced the problem to some third-party kernel modules
(the Linuxant hsfmodem drivers for my Conexant modem). 

--David

Comment 7 Godmar Back 2004-02-18 11:33:58 EST
More specifically, my hangup is similar to the others in that it comes
back at first, but dies once you access the harddisk.  If you switch
to the console and do Ctrl-Alt-Del, you'll the message about hda: lost
interrupt that Bjoern was describing.
Comment 8 Bjorn Knutsson 2004-02-18 12:00:07 EST
I've put my config for the vanilla 2.4.24 up as
http://www.cis.upenn.edu/~bjornk/T23-2.4.24.config

This works for me, both with suspend and hibernate to disk. (The
latter requires that you have a FAT32 partition containing a proper
hibernation file.)

Together with Tomas Janousek's db4-package, everything seems to work
fine. (If you use a vanilla kernel without the NPTL-patches, then db4
as distributed will not work properly. See
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=91933 for details
and a pointer to Tomas' replacement package. I've used it for a month
and a half, and the things that didn't work before seems to work now.)

/Bjorn
Comment 9 David Lawrence 2004-09-29 15:53:07 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.