Bug 1126793 - [ovirt-engine-sdk] AttributeError: 'Users' object has no attribute 'get_owner'
Summary: [ovirt-engine-sdk] AttributeError: 'Users' object has no attribute 'get_owner'
Keywords:
Status: CLOSED DUPLICATE of bug 1125161
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-sdk
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Juan Hernández
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 09:56 UTC by Ondra Machacek
Modified: 2014-08-05 13:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-05 09:58:20 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Ondra Machacek 2014-08-05 09:56:06 UTC
Description of problem:


Version-Release number of selected component (if applicable):
ovirt-engine-sdk-python-3.5.0.3-1.20140712.git73490d1.el6.noarch

How reproducible:
always

Steps to Reproduce:
#!/usr/bin/env python
import ovirtsdk.api
from ovirtsdk.xml import params

API = ovirtsdk.api.API(url='https://localhost:443/api', insecure=True,
        username='admin@internal', password='password', filter=False, debug=False)

for i in API.users.list():
    print i.get_name()

for i in API.domains.list()[0].users.list():
    print i.get_name()

Actual results:
Traceback (most recent call last):
  File "./spam.py", line 8, in <module>
    for i in API.users.list():
  File "/usr/lib/python2.6/site-packages/ovirtsdk/infrastructure/brokers.py", line 18746, in list
    headers={}
AttributeError: 'Users' object has no attribute 'get_owner'


Expected results:
list engine users and domain users

Additional info:

Comment 1 Ondra Machacek 2014-08-05 09:58:20 UTC

*** This bug has been marked as a duplicate of bug 1125161 ***


Note You need to log in before you can comment on or make changes to this bug.