Bug 1126804 - [abrt] pylint: pkg_resources.py:576:resolve:pkg_resources.DistributionNotFound: pylint==1.2.0
Summary: [abrt] pylint: pkg_resources.py:576:resolve:pkg_resources.DistributionNotFoun...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pylint
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:fe126712c0cdb99a8a136dce181...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 10:40 UTC by redhat
Modified: 2014-10-28 01:49 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-27 21:12:15 UTC


Attachments (Terms of Use)
File: backtrace (939 bytes, text/plain)
2014-08-05 10:40 UTC, redhat
no flags Details
File: environ (3.02 KB, text/plain)
2014-08-05 10:40 UTC, redhat
no flags Details

Description redhat 2014-08-05 10:40:11 UTC
Version-Release number of selected component:
pylint-1.2-6.fc20

Additional info:
reporter:       libreport-2.2.3
cmdline:        /usr/bin/python3 /usr/bin/python3-pylint-gui
executable:     /usr/bin/python3-pylint-gui
kernel:         3.15.7-200.fc20.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
pkg_resources.py:576:resolve:pkg_resources.DistributionNotFound: pylint==1.2.0

Traceback (most recent call last):
  File "/usr/bin/python3-pylint-gui", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.3/site-packages/pkg_resources.py", line 2793, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python3.3/site-packages/pkg_resources.py", line 673, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.3/site-packages/pkg_resources.py", line 576, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: pylint==1.2.0

Local variables in innermost frame:
to_activate: []
req: Requirement.parse('pylint==1.2.0')
best: {'pylint': None}
requirements: []
dist: None
env: <pkg_resources.Environment object at 0x7f521f8ba390>
self: <pkg_resources.WorkingSet object at 0x7f521f8ba350>
processed: {}
installer: None

Comment 1 redhat 2014-08-05 10:40:13 UTC
Created attachment 924170 [details]
File: backtrace

Comment 2 redhat 2014-08-05 10:40:15 UTC
Created attachment 924171 [details]
File: environ

Comment 3 Brian Lane 2014-10-16 23:46:02 UTC
Is this still happening with pylint-1.3.1?

Comment 4 Alec Leamas 2014-10-26 08:41:31 UTC
Yes :(

Comment 5 Alec Leamas 2014-10-26 12:37:37 UTC
Work around: install the source package using python or python3. Works fine under python3.

Comment 6 Brian Lane 2014-10-27 21:06:20 UTC
Ok, I think I see what's going on. If you only install pylint-gui you don't get the python3 version and you get the above error. You should also install python3-pylint-gui and python3-tkinter (I just discovered that it has a missing dep).

Comment 7 Alec Leamas 2014-10-27 22:04:43 UTC
Missing dep -> NOTABUG ?! That said, installing packages menioned in comment #6 fixes problem, thanks!

Comment 8 Brian Lane 2014-10-28 01:49:30 UTC
There is no option for NOTTHISBUG :)

I've built a new one with the correct Require in it.


Note You need to log in before you can comment on or make changes to this bug.