Bug 1126805 - webnotifications broken in firefox-31.0-2
Summary: webnotifications broken in firefox-31.0-2
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: 20
Hardware: All Linux
unspecified
high
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL: http://www.bennish.net/web-notificati...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 10:54 UTC by Heiko Adams
Modified: 2014-11-27 13:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-27 13:24:29 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 858919 None None None Never

Description Heiko Adams 2014-08-05 10:54:53 UTC
Description of problem:
After updating to firefox-31.0-2 webnotifications no longer seem to work. When using the notification-test at http://www.bennish.net/web-notifications.html no notifications are shown with firefox-31.0-2 while everything worked fine with firefox-31.0-1

Version-Release number of selected component (if applicable):
firefox-31.0-2.fc20.x86_64

How reproducible:
allways

Steps to Reproduce:
1. Navigate to http://www.bennish.net/web-notifications.html
2. Click on "Authorize"
3. Click on "Show"

Actual results:
No notification is shown

Expected results:
There should be a notification

Additional info:

Comment 1 Martin Stransky 2014-08-05 11:07:55 UTC
It's because the notificatin from bennish.net uses unsupported tags - libnotify does not support them.

Test a simple notification at https://developer.mozilla.org/en-US/docs/Web/API/Notification/Using_Web_Notifications

Comment 2 Heiko Adams 2014-08-05 11:49:26 UTC
So you're saying that the patch is waste because it makes a function, which previously works on *any* pages, now working only on pages which fulfill some special conditions?

Maybe you should take a look at the GNotifier (https://addons.mozilla.org/de/firefox/addon/gnotifier/) extension for inspiration.

Comment 3 Martin Stransky 2014-08-05 11:58:55 UTC
No, I say that libnotify library which is used by Firefox does not support all tags which can be used by notification system. See https://bugzilla.mozilla.org/show_bug.cgi?id=858919 for details.

Comment 4 Martin Stransky 2014-08-05 11:59:37 UTC
And https://bugzilla.mozilla.org/show_bug.cgi?id=858919 for the recent libnotify implementation.

Comment 5 Heiko Adams 2014-08-05 12:13:29 UTC
So libnotify needs to be updates too?

Comment 6 Heiko Adams 2014-08-30 21:43:34 UTC
Any progress on this or do you want to ship a firefox package with an almost broken webnotifications function until firefox's libnotify supports all possible tags?

Comment 7 Martin Stransky 2014-09-01 07:17:39 UTC
In short - yes. The package got karma and positive feedback from testers in Bodhi. The same patch it's used in Ubuntu for instance. Plus the patch was a part of Firefox for long time and nobody had complained since the removal.

Comment 8 Martin Stransky 2014-09-01 07:23:28 UTC
To be clear - I understand your concerns but I also need to take feedback from other uses and I don't see many other complains and the overall feedback is positive. So it looks better solution to me to include the patch for now.

Comment 9 Heiko Adams 2014-09-01 19:28:04 UTC
I've tested this with Ubuntu 14.10 Beta on my working notebook and their firefox 32 package and everything works fine with http://www.bennish.net/web-notifications.html. But with fedora's firefox 32 package these notifications still don't work. 

And AFAIK popular german websites like heise are using similar notifications.

Comment 10 Martin Stransky 2014-09-02 11:05:59 UTC
I see. And does Ubuntu use a system notifications or the Firefox (internal) ones? Because some feature were not implemented by libnotify interface in Firefox. So Ubuntu may use Firefox internal notifications or implemented some libnotify fixes.

Comment 11 Heiko Adams 2014-09-02 20:16:05 UTC
It looks like they're still using firefox internal notification system.

Comment 13 Heiko Adams 2014-10-18 13:45:09 UTC
ATM I can't test your packages because I've made a relocation and my internet connection is ATM a very slow wifi connection. So I'll test and report back in a week or two after getting back my normal internet connection.

Comment 14 Heiko Adams 2014-10-22 17:56:28 UTC
I've made a short test with http://www.bennish.net/web-notifications.html and heise.de and in both cases webnotifications are working again without GNotifier. Thanks \o/

Comment 15 Martin Stransky 2014-11-27 13:24:29 UTC
Should br fixed now in latest Firefox-33.1.


Note You need to log in before you can comment on or make changes to this bug.