Bug 1126812 - Sybase metadata loading fails
Summary: Sybase metadata loading fails
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER1
: 6.1.0
Assignee: Van Halbert
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 11:07 UTC by Filip Elias
Modified: 2015-06-22 15:27 UTC (History)
1 user (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
DV 6.1 DR2
Last Closed: 2014-08-07 13:40:08 UTC
Type: Bug


Attachments (Terms of Use)
Server log with the exception (302.35 KB, text/x-log)
2014-08-05 11:07 UTC, Filip Elias
no flags Details


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker JBDVPL-62 Major Ready for QA Improve Usability of Teiid connection importer 2016-10-06 16:27:16 UTC
JBoss Issue Tracker TEIID-3064 Major Closed Sybase metadata loading fails 2016-10-06 16:27:16 UTC

Description Filip Elias 2014-08-05 11:07:56 UTC
Created attachment 924172 [details]
Server log with the exception

Sybase metadata loading fails[1] when deploying dynamic vdb.

The problem is in JDBCMetdataProcessor.getForeignKeys. Method loads FKs from all tables, but it fails when it tries to load FKs from table sysquerymetrics. The problem seems to be that sysquerymetrics is not a system table, it is a view.

[1] Reason:TEIID11010 com.sybase.jdbc4.jdbc.SybSQLException: No such object or user exists in the database.

Comment 1 JBoss JIRA Server 2014-08-07 13:14:33 UTC
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-3064 to Resolved

Comment 3 JBoss JIRA Server 2014-08-07 13:40:46 UTC
Van Halbert <vhalbert@jboss.org> updated the status of jira JBDVPL-62 to Resolved

Comment 4 JBoss JIRA Server 2015-06-22 15:27:42 UTC
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-3064 to Closed


Note You need to log in before you can comment on or make changes to this bug.