Bug 1126818 - Package upgrade changes libproj dependency
Summary: Package upgrade changes libproj dependency
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: mirall
Version: 20
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Nikos Roussos
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 11:24 UTC by Greg Harvey
Modified: 2015-06-29 21:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-29 21:56:45 UTC


Attachments (Terms of Use)

Description Greg Harvey 2014-08-05 11:24:12 UTC
Description of problem:

I can't be 100% sure, because I haven't been using the client, but I'm 99% sure the upgrade of 26th May 2014 broke owncloud for Fedora 20 64-bit. It was fine, but after that upgrade I got this message:

owncloud: error while loading shared libraries: libproj.so.0: cannot open shared object file: No such file or directory

After some poking around on Google, checking links exist, etc. I noted I only had the 32-bit version of proj installed so decided to try this:

yum install proj.x86_64

Right after, /usr/lib64/libproj.so.0 came into existence and mirall was fine again. I've seen issues with other projects worked around by adding the libproj.so.0 file to lib64 with a link, but that seems dirty as the package is probably *expecting* a 64-bit library.

In any case, seems like a bug - not sure if it's a packaging problem or something else, but I couldn't find another report so figured I'd raise this.

Version-Release number of selected component (if applicable):

$ rpm -qi mirall
Name        : mirall
Version     : 1.5.4
Release     : 2.fc20
Architecture: x86_64
Install Date: Sat 02 Aug 2014 08:36:40 CEST
Group       : Unspecified
Size        : 2270316
License     : GPLv2+
Signature   : RSA/SHA256, Tue 06 May 2014 17:08:13 CEST, Key ID 2eb161fa246110c1
Source RPM  : mirall-1.5.4-2.fc20.src.rpm
Build Date  : Tue 06 May 2014 16:00:02 CEST
Build Host  : buildvm-21.phx2.fedoraproject.org
Relocations : (not relocatable)
Packager    : Fedora Project
Vendor      : Fedora Project
URL         : http://owncloud.org/sync-clients/
Summary     : The ownCloud Client
Description :
Mirall owncloud-client enables you to connect to your private
ownCloud Server. With it you can create folders in your home
directory, and keep the contents of those folders synced with your
ownCloud server. Simply copy a file into the directory and the
ownCloud Client does the rest.


How reproducible:

A little tricky to reproduce unless you have a system with the previous version installed and specifically *without* proj.x86_64 installed - presumably a clean install would be OK with the latest package.

Steps to Reproduce:

I haven't tried this, but you might be able to:

1. Install Fedora 20 64 bit on a new system / VM
2. Install an older version of mirall for Fedora 20 (e.g. http://download.fedoraproject.org/pub/fedora/linux/releases/20/Everything/x86_64/os/Packages/m/mirall-1.4.2-1.fc20.x86_64.rpm)
3. yum update mirall
4. owncloudcmd

Actual results:

$ owncloudcmd 
owncloudcmd: error while loading shared libraries: libproj.so.0: cannot open shared object file: No such file or directory

Expected results:

$ owncloudcmd 
owncloudcmd - command line ownCloud client tool.

Usage: owncloudcmd <sourcedir> <owncloudurl>

A proxy can either be set manually using --httpproxy or it
uses the setting from a configured sync client.

Options:
  --confdir = configdir: Read config from there.
  --httpproxy = proxy:   Specify a http proxy to use.
                         Proxy is http://server:port


Additional info:

Comment 1 Fedora Admin XMLRPC Client 2014-08-29 01:10:09 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Fedora End Of Life 2015-05-29 12:33:59 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 3 Fedora End Of Life 2015-06-29 21:56:45 UTC
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.