Bug 1126832 - glusterfs.spec.in: deprecate *.logrotate files in dist-git in favor of the upstream logrotate files
Summary: glusterfs.spec.in: deprecate *.logrotate files in dist-git in favor of the up...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On: 1126788
Blocks: 1099539 1159968 1159970 1181315 1204085
TreeView+ depends on / blocked
 
Reported: 2014-08-05 11:53 UTC by Kaleb KEITHLEY
Modified: 2015-12-01 16:45 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1126788
: 1159968 1159970 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:27:00 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2014-08-05 11:53:22 UTC
+++ This bug was initially created as a clone of Bug #1126788 +++

Description of problem:

Glusterfs's logrotate config file in the /etc/logrotate.d directory pollutes logrotate's global config file at /etc/logrotate.conf.  Namely, the file /etc/logrotate.d/glusterfs-georep has global directives in the beginning of the file that reads

"""

rotate 52
missingok

compress
delaycompress
notifempty

"""

When this file is included into logrotate's config file (line 18 of /etc/logrotate.conf, which reads "include /etc/logrotate.d"), it is splashed into the state of logrotate's config reader, "as if it was included inline" (man logrotate).  Therefore, those lines will override whatever corresponding configuration terms already present in /etc/logrotate.conf.

Especially, the "rotate 52" directive will delay the removal of old logs up to a year globally (!!), resulting in a large number of old logs that should have been deleted.

Please move the above directives inside the curly braces so they don't pollute the global config state.


Version-Release number of selected component (if applicable):

glusterfs-3.5.2-1.fc20


How reproducible:

Very.


Steps to Reproduce:

1.  Install glusterfs.
2.  Watch old logs grow;  output of logrotate -d /etc/logrotate.conf showing "52 rotations" not just for glusterfs georeplication logs but almost all other logs.


Actual results:

Many old logs are not removed.  logrotate -d /etc/logrotate.conf output shows "52 rotations" for all logs processed after glusterfs-georep that don't override the "rotate" directive individually.


Expected results:

Should not have interfered with other logs.


Additional info:

The spurious old logs caused by this still needs manual removal after the fix, because logrotate, given "rotate 4" directive, won't even touch beyond the 5th log file.

--- Additional comment from Niels de Vos on 2014-08-05 06:29:37 EDT ---

Filed upstream Gluster Community Bug 1126801 for getting a fix included in the next release.

This bug will be used to track the status of the fix for the Fedora package(s).

--- Additional comment from Kaleb KEITHLEY on 2014-08-05 07:44:20 EDT ---

Upstream has extras/glusterfs{,-georep}-logrotate files which we should be using exclusively. 

Currently it appears that we install both the upstream and dist-git logrotate files in /etc/logrotate.d and because we use a wildcard in the %files section of the glusterfs.spec we (erroneously) package all of them.

Changed the summary accordingly.

Comment 1 Anand Avati 2014-08-05 12:31:31 UTC
REVIEW: http://review.gluster.org/8418 (glusterfs.spec.in: use upstream logrotate exclusively) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Anand Avati 2014-08-08 14:29:11 UTC
REVIEW: http://review.gluster.org/8418 (glusterfs.spec.in: use upstream logrotate exclusively) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 3 Anand Avati 2014-10-27 17:31:50 UTC
REVIEW: http://review.gluster.org/8418 (glusterfs.spec.in: use upstream logrotate exclusively) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 4 Anand Avati 2014-10-28 08:41:38 UTC
COMMIT: http://review.gluster.org/8418 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit c35135c8da3542f377dcb22d121d255eb796a819
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Tue Aug 5 08:29:42 2014 -0400

    glusterfs.spec.in: use upstream logrotate exclusively
    
    retiring Fedora dist-git *.logrotate files
    
    Change-Id: I6a94aac6f45573216de3f9e673d10db6de5ccb98
    BUG: 1126832
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/8418
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 5 Niels de Vos 2015-05-14 17:27:00 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:35:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:37:53 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-05-14 17:43:05 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.