Bug 1126842 - config_macros.yml causes hammer to fail to start (Psych::SyntaxError)
Summary: config_macros.yml causes hammer to fail to start (Psych::SyntaxError)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Transitions
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Grant Gainey
QA Contact: Lukas Pramuk
URL:
Whiteboard:
Depends On:
Blocks: stargate-GA-tracker
TreeView+ depends on / blocked
 
Reported: 2014-08-05 12:24 UTC by Lukas Pramuk
Modified: 2019-09-26 14:45 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:25:37 UTC


Attachments (Terms of Use)

Description Lukas Pramuk 2014-08-05 12:24:58 UTC
Description of problem:
config_macros.yml causes hammer to fail to start (Psych::SyntaxError)

Version-Release number of selected component (if applicable):
rubygem-hammer_cli_import-0.9.1-1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. # hammer
/usr/share/ruby/psych.rb:205:in `parse': (<unknown>): found character that cannot start any token while scanning for the next token at line 5 column 57 (Psych::SyntaxError)
	from /usr/share/ruby/psych.rb:205:in `parse_stream'
	from /usr/share/ruby/psych.rb:153:in `parse'
	from /usr/share/ruby/psych.rb:129:in `load'
	from /usr/share/gems/gems/hammer_cli-0.1.1/lib/hammer_cli/settings.rb:38:in `load_from_file'
	from /usr/share/gems/gems/hammer_cli-0.1.1/lib/hammer_cli/settings.rb:25:in `block (2 levels) in load_from_paths'
	from /usr/share/gems/gems/hammer_cli-0.1.1/lib/hammer_cli/settings.rb:24:in `each'
	from /usr/share/gems/gems/hammer_cli-0.1.1/lib/hammer_cli/settings.rb:24:in `block in load_from_paths'
	from /usr/share/gems/gems/hammer_cli-0.1.1/lib/hammer_cli/settings.rb:16:in `each'
	from /usr/share/gems/gems/hammer_cli-0.1.1/lib/hammer_cli/settings.rb:16:in `load_from_paths'
	from /usr/share/gems/gems/hammer_cli-0.1.1/bin/hammer:39:in `<top (required)>'
	from /usr/bin/hammer:23:in `load'
	from /usr/bin/hammer:23:in `<main>'

Comment 1 RHEL Product and Program Management 2014-08-05 12:34:03 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Grant Gainey 2014-08-05 12:54:43 UTC
commit 823eadfd7ba52ab89dbce9f2ab0cce69dca4a14b

Comment 6 Matej Kollar 2014-09-03 09:33:51 UTC
verified with rubygem-hammer_cli_import-0.10.3-1

Comment 7 Matej Kollar 2014-09-03 09:38:04 UTC
This bug is related to Bug #1126882

Comment 8 Bryan Kearney 2014-09-11 12:25:37 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.