Bug 1126856 - Unable to add iSCSI LUN : value too long for type character varying(50)
Summary: Unable to add iSCSI LUN : value too long for type character varying(50)
Keywords:
Status: CLOSED DUPLICATE of bug 1052839
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.1
Assignee: bugs@ovirt.org
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 13:04 UTC by Denis GERMAIN
Modified: 2014-08-06 08:00 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 08:00:07 UTC
oVirt Team: ---


Attachments (Terms of Use)
Relevant portion of engine log (22.72 KB, text/plain)
2014-08-05 13:04 UTC, Denis GERMAIN
no flags Details

Description Denis GERMAIN 2014-08-05 13:04:26 UTC
Created attachment 924212 [details]
Relevant portion of engine log

Description of problem:
Impossible to add an iSCSI storage domain. I can connect/login on the target, I can see the disks, but I can't finish the storage domain creation. 

Version-Release number of selected component (if applicable):
I run ovirt 3.4.0-1.el6 on the main node via both ovirt and VDSM on a CentOS (RHEL - 6 - 5.el6.centos.11.2) and a VDSM node only (oVirt Node - 3.0.4 - 1.0.201401)

How reproducible:
Every time

Steps to Reproduce:
1. In the storage domain list from the ovirt web console, I add a new storage domain
2. Choose the iSCSI Storage Type, add an username and password in the "User Authentication" section, select an available LUN and click OK
3. The popup run for a few minutes then tells me that there has been an error (Failed to add Storage Domain)

Actual results:
ovirt core connects correctly on the iscsi disk, begins to write informations on it (an LVM VG and LVs are created), but after that the process seems to fail and the storage domain doesn't appear in the storage domain list

Expected results:
The storage domain should appear in the storage domain list

Additional info:
There seems to be an error in a SQL request (extract from engine.log) :
Command org.ovirt.engine.core.bll.storage.AddSANStorageDomainCommand throw exception [...] ERREUR: valeur trop longue pour le type character varying(50)
PL/pgSQL function "insertstorage_server_connections"

Comment 1 Allon Mureinik 2014-08-06 08:00:07 UTC
This was solved in oVirt 3.4.1 (see bug 1052839).

*** This bug has been marked as a duplicate of bug 1052839 ***


Note You need to log in before you can comment on or make changes to this bug.