Bug 1126893 - [abrt] pylint: getopt.py:211:short_has_arg:getopt.GetoptError: option -V not recognized
Summary: [abrt] pylint: getopt.py:211:short_has_arg:getopt.GetoptError: option -V not ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pylint
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:a7ba67e59f6a2c160762e8bae49...
: 1227822 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 14:15 UTC by redhat
Modified: 2015-06-03 17:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 00:05:25 UTC


Attachments (Terms of Use)
File: backtrace (950 bytes, text/plain)
2014-08-05 14:15 UTC, redhat
no flags Details
File: environ (1.79 KB, text/plain)
2014-08-05 14:15 UTC, redhat
no flags Details

Description redhat 2014-08-05 14:15:22 UTC
Version-Release number of selected component:
pylint-1.2-6.fc20

Additional info:
reporter:       libreport-2.2.3
cmdline:        /usr/bin/python3 /usr/bin/python3-symilar -V
executable:     /usr/bin/python3-symilar
kernel:         3.15.7-200.fc20.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
getopt.py:211:short_has_arg:getopt.GetoptError: option -V not recognized

Traceback (most recent call last):
  File "/usr/bin/python3-symilar", line 9, in <module>
    load_entry_point('pylint==1.2.0', 'console_scripts', 'symilar')()
  File "/usr/lib/python3.3/site-packages/pylint/__init__.py", line 44, in run_symilar
    Run(sys.argv[1:])
  File "/usr/lib/python3.3/site-packages/pylint/checkers/similar.py", line 344, in Run
    opts, args = getopt(argv, s_opts, l_opts)
  File "/usr/lib64/python3.3/getopt.py", line 95, in getopt
    opts, args = do_shorts(opts, args[0][1:], shortopts, args[1:])
  File "/usr/lib64/python3.3/getopt.py", line 195, in do_shorts
    if short_has_arg(opt, shortopts):
  File "/usr/lib64/python3.3/getopt.py", line 211, in short_has_arg
    raise GetoptError(_('option -%s not recognized') % opt, opt)
getopt.GetoptError: option -V not recognized

Local variables in innermost frame:
shortopts: 'hdi'
i: 2
opt: 'V'

Comment 1 redhat 2014-08-05 14:15:25 UTC
Created attachment 924223 [details]
File: backtrace

Comment 2 redhat 2014-08-05 14:15:26 UTC
Created attachment 924224 [details]
File: environ

Comment 3 Brian Lane 2014-10-17 00:05:25 UTC
This is how it treats unknown options.

Comment 4 Brian Lane 2015-06-03 17:03:28 UTC
*** Bug 1227822 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.