Bug 112691 - Problems to install if more then 1 CD drive present
Problems to install if more then 1 CD drive present
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-28 11:00 EST by Stefan Sturm
Modified: 2007-04-18 13:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 16:15:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a possible bugfix file (31.75 KB, text/plain)
2003-12-28 11:02 EST, Stefan Sturm
no flags Details

  None (edit)
Description Stefan Sturm 2003-12-28 11:00:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

Description of problem:
See bug 85861, which says it all. It is for sure reproducable, and a
bugfix file has been attached.

1.Even though the first drive is the good one, the installer will
probe all drives, causing install to fail to mount the CDROM, since it
tries the good one first, mounts but continues trying the next drive.

2. Info about the drives is tried on the wrong device, more then 1
device present, and the first is unmounted, but still default.

Maybe this explanation is difficult to understand, but a diff of the
attached file might help :-)

Similar to bug 84748, which might be solved with this one too.


Version-Release number of selected component (if applicable):
1.1.9-1

How reproducible:
Always

Steps to Reproduce:
1.start program without discs inserted
2.try to install 1 packages.
3.after inserting the disc on request, the error happens
4.program stops -> Another bug ?

Make sure you have more then 1 device (cdrom, cdrom1)

Expected Results:  1. We should install

But..

2. If it fails, I like to see the correct reason (only visible when
started in a terminal)
3. If it fails to mount a drive or find a package file, it should
return to the main window, allowing more or other updates

Additional info:

This is the trace I added myself to debug. Added a lot of extra
printing...

CIM init
CIM readHeaders
CIM readCompsViaMethod
* Core references package efibootmgr which doesn't exist
* Core references package elilo which doesn't exist
CIM getFilename
CIM umount /mnt/cdrom
CIM mount /mnt/cdrom1
mount returns 1
CIM mount /mnt/cdrom
mount returns 1
 
 
 
 
Trying dev /dev/cdrom1
CIM mount /mnt/cdrom1
CIM getDiscs /mnt/cdrom
  Problem with mounted discs
mount returns 0
All right
Trying dev /dev/cdrom
CIM mount /mnt/cdrom
CIM umount /mnt/cdrom1
mount returns 1
CIM mount /mnt/cdrom
mount returns 1
/mnt/cdrom1/RedHat/RPMS/blas-3.0-20.i386.rpm
Het bestand /mnt/cdrom1/RedHat/RPMS/blas-3.0-20.i386.rpm kan niet
worden geopend. De oorzaak hiervan is een ontbrekend bestand, een
beschadigd pakket of beschadigde media. Druk op <enter> om opnieuw te
proberen.
Comment 1 Stefan Sturm 2003-12-28 11:02:43 EST
Created attachment 96715 [details]
a possible bugfix file
Comment 2 Stefan Sturm 2004-01-11 14:15:07 EST
Additional info : try to install from the second drive in a 2 drive
system...
Comment 3 Jeremy Katz 2005-09-21 16:15:31 EDT
This report is filed against a product which is no longer supported.  It is very
likely that the problem is resolved in the current version of Fedora Core or
scheduled to be resolved with the new system-config-packages scheduled to land
in Fedora Core 5.

Note You need to log in before you can comment on or make changes to this bug.