Bug 1126923 - upload bundle recipe button does not work for first time
Summary: upload bundle recipe button does not work for first time
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER01
: JON 3.3.0
Assignee: Jirka Kremser
QA Contact: Armine Hovsepyan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 15:21 UTC by Armine Hovsepyan
Modified: 2015-09-03 00:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-11 14:04:18 UTC
Type: Bug


Attachments (Terms of Use)

Description Armine Hovsepyan 2014-08-05 15:21:51 UTC
Description of problem:
upload bundle recipe  button does not work for first time 

Version-Release number of selected component (if applicable):
jon 3.3 dr1

How reproducible:
always

Steps to Reproduce:
1. navigate to Bundles
2. click on create new bundle button
3. chose upload recipe
4. try uploading a recipe

Actual results:
does not select the file for upload for first time and works for the second time


Expected results:
uploading bundle recipe (as well as any other file upload) should work from first try

Additional info:
This is a regression in patternfly that can/will break our automation tests

Comment 1 Jirka Kremser 2014-08-12 14:22:30 UTC
This was fixed and verified in dr1. See bug 1117760. I've just tried the repro steps on jon 3.3 DR1 and it worked.

Perhaps I should close it as a duplicate instead of moving it to ON_QA. But just for sure let's do another round (because of the keyword "regression")

Comment 2 Jirka Kremser 2014-08-13 10:00:25 UTC
So it is not working for bundle _recipe_ upload button. I was trying it only for the distribution file upload, mea culpa. So moving it back to assigned. I've fixed the issue for UI component called org.rhq.coregui.client.components.upload.FileUploadForm, but in this case the org.rhq.coregui.client.components.upload.TextFileRetrieverForm was used. 

I'll double check the situation for all the classes in that package.

Comment 3 Jirka Kremser 2014-08-13 13:52:50 UTC
branch:  master
link:    https://github.com/rhq-project/rhq/commit/2fdde925a
time:    2014-08-13 15:50:13 +0200
commit:  2fdde925af5f1662d6b3e19b06f84491ad577f73
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1126923] - upload bundle recipe button does not work for first time
         - doing the same changes as introduced in commit
         132e2f1f0fa5d31 for component TextFileRetrieverForm.

cherry-picked to:

branch:  release/jon3.3.x
link:    https://github.com/rhq-project/rhq/commit/bb8778f0f
time:    2014-08-12 06:37:20 -0700
commit:  bb8778f0fe3d2ca38d4f9af8b8f01408ab22e704
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1128276] - Custom time range, if set with invalid wrong range,
         cannot set back - Adding a client side validation in web UI

         (cherry picked from commit
         67c7f3f024e99b90b8412d0da8c4d0cc4971c492) Signed-off-by: Mike
         Thompson <mithomps@redhat.com>

Comment 4 Simeon Pinder 2014-08-19 23:50:43 UTC
Moving to ON_QA as available to test in the following brew build:

https://brewweb.devel.redhat.com//buildinfo?buildID=379025

Comment 5 Armine Hovsepyan 2014-08-20 08:35:42 UTC
verified, thank you
Version : 3.3.0.ER01
Build Number :	23b3476:f3aa7e7


Note You need to log in before you can comment on or make changes to this bug.