Bug 1126946 - [rpm] unable to install sgi-fonts-1.0-1
Summary: [rpm] unable to install sgi-fonts-1.0-1
Keywords:
Status: CLOSED DUPLICATE of bug 1122004
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 21
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 16:12 UTC by Joachim Frieben
Modified: 2014-08-12 08:16 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-12 08:16:13 UTC


Attachments (Terms of Use)
SGI fonts package (155.30 KB, application/x-rpm)
2014-08-05 16:12 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2014-08-05 16:12:43 UTC
Created attachment 924256 [details]
SGI fonts package

Description of problem:
After upgrading to Fedora 21, rpm refuses to install sgi-fonts-1.0-1.noarch.rpm.

Version-Release number of selected component (if applicable):
rpm-4.11.90-0.git12844.5.fc21

How reproducible:
Always

Steps to Reproduce:
1. rpm -Uhv sgi-fonts-1.0-1.noarch.rpm

Actual results:
error: unpacking of archive failed: cpio: Archive file not in header
error: sgi-fonts-1.0-1.noarch: install failed

Expected results:
Package installs as expected.

Additional info:
It was possible to install sgi-fonts-1.0-1.noarch.rpm for the last 15 years on Red Hat/Fedora without a problem including the current release Fedora 20 :o/

Comment 1 Panu Matilainen 2014-08-06 08:15:57 UTC
Might be related to/same as bug 1122004, the package is truly ancient (built with rpm 3.0.3) and does not have compressed filelist, just like 1122004 was built with newer rpm but --nodirtokens.

In any case, its a regression that needs fixing. Florian?

Comment 2 Panu Matilainen 2014-08-12 08:16:13 UTC
Closer inspection reveals this is indeed a duplicate of 1122004, compatibility with truly ancient package payloads got broken in 4.12 (more or less intentionally, that these packages still exist is kind of surprising)

*** This bug has been marked as a duplicate of bug 1122004 ***


Note You need to log in before you can comment on or make changes to this bug.