Bug 1126951 - Glance user failed to create during packstack deployment
Summary: Glance user failed to create during packstack deployment
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 5.0 (RHEL 7)
Assignee: Gaël Chamoulaud
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 17:08 UTC by ygoitom
Modified: 2018-10-15 16:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-25 09:37:43 UTC


Attachments (Terms of Use)
Log files (3.34 KB, application/x-gzip)
2014-08-05 17:08 UTC, ygoitom
no flags Details

Description ygoitom 2014-08-05 17:08:31 UTC
Created attachment 924260 [details]
Log files

Description of problem:
During packstack deplyoment, glance user is not created

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Packstack errors out when trying to run the glance manifests

Expected results:
Run packstack and succeed configuring glance without errors

Additional info:

- Workaround
 1. Either run the following commands
  #####
   groupadd -g 161 glance
   useradd -u 161 -g 161 -r -d /var/lib/glance -s /sbin/nologin -c "OpenStack Glance Daemons" glance
  #####

  2. Re-run packstack after it has created the user and it will succeed.

Comment 2 Gaël Chamoulaud 2014-09-10 13:46:54 UTC
Hi Yonathan,

Users are created by the rpm packages:

$ rpm -q --scripts openstack-glance
...
preinstall scriptlet (using /bin/sh):                              
getent group glance >/dev/null || groupadd -r glance -g 161        
getent passwd glance >/dev/null || \                               
useradd -u 161 -r -g glance -d /var/lib/glance -s /sbin/nologin \  
-c "OpenStack Glance Daemons" glance                               
exit 0                                                             
...

I can't reproduce your issue, so could you be able to give more information ?

Cheers,
Gaël.


Note You need to log in before you can comment on or make changes to this bug.